Unwanted sass syntax highlighting


#1

Hello,

New to atom and enjoying using it.

however, I have encountered a syntax highlighting problem that I cannot resolve.

I am using the core sass language support package with unexpected results:

keywords (such as, for colors or sass tools) are being highlighted in bright red, this is extremely distracting. Have tried disabling spell check, to no avail.

I am looking for a way to disable this highlighting.

Any help or suggestions here would be greatly appreciated.

Thanks in advance,

Paul.


#2

You’re seeing these highlights because the properties aren’t standard ones so they are wrapped in a .invalid.illegal span, you can tweak the styles of these properties with something like that in your user stylesheet:

atom-text-editor, atom-text-editor::shadow {
  .invalid.illegal {
    background: transparent;
  }
}

#3

Thanks for your reply abe. Your suggestion did the trick.

I had to add the !important keyword to override the red styles.