Unpublish userlite-link


#1

I have a package userlite-link that I deleted the github repo for and want to start over on. I realize that I should have unpublished the package first. @leedohm can you help me out and delete it from apm so I can start over on it?


#2

Have you tried apm unpublish?


#3

Yeah, you can’t unpublish if you’ve deleted the GitHub repo.


#4

That issue has been fixed for around a month now. Are you sure apm unpublish is unable to unpublish your package? Can you paste the error output that you’re receiving here?


#5

Ah, I did not know that. Thanks for the heads up @Wliu! The error I get on apm unpublish is Unpublishing failed: Unauthorized. The repo is owned by an organization ‘Userlite’ on GitHub and I’m a member of the organization.

There was another package that I unpublished just yesterday that was owned by Userlite and I didn’t have any problems with it. I assumed the problem with userlite-link was that I had deleted the github repo associated with it.

I also tried recreating the userlite-link repo to see if that would help but no luck.

Thanks for any advice!


#6

A couple other things to mention that just came to mind.

I deleted the userlite-link repo from github several months ago which would have been before the unpublish fix was in place. I’m not sure if that matters at all but just wanted to put that out there.

Also my intention is to use the userlite-link package name for a rebuild. I don’t necessarily care to have it deleted if I could commit to it. I created a new repo called userlite-link and tried an apm publish but I get an error that apm can’t find the correct tags.

Seems like the easiest thing would be to just get it deleted and start over.


#7

Hmm, things may be a bit different if the repository was part of an organization - I can’t quite remember the rules of who is allowed to unpublish a deleted repository. Guess we’ll wait for Lee then :grinning:.


#8

I ran into this before (I think) - to unpublish the package, the Atom.io application needs access to your organization which can be prevented if you have 3rd party application restrictions enabled 1. If you’re an organization owner @danseethaler, the process to grant Atom.io access to your organization is basically detailed here:

https://help.github.com/articles/requesting-organization-approval-for-third-party-applications/

The difference is that if you’re an owner, you won’t be requesting access, you can directly grant access and you’ll see a “Grant access” button. If you’re not an owner, you’ll need to request access and an organization owner will need to approve it. After this is done, go ahead and try unpublishing and publishing again.


#9

@rsese hurray!!! Nailed it friend. Thanks for the insight and the links.


#10

Glad to hear it, h/t @jasonrudolph for helping me with this same issue a few weeks back :tophat: