Unpublish Package problem


#1

I made a theme package and had trouble with getting to see feedback from the theme when I made changes, I think I accidentally uninstalled the theme.

So I deleted everything, the repository, the folder, to start new and tried to unpublish the atom.io package thing and it says I’m not authorized.

I remade the theme and now I can’t publish it, I think because of the package on atom.io or something similar to my problem above.

Any advice?


#2

Have you tried apm login and then apm unpublish <package name>?


#3

You can’t unpublish a package if the repository doesn’t exist anymore. If I’m correct, creating an empty repository at the same location should be enough to unpublish your package.


#4

Created a repository under the same name, and when trying leedohm’s suggestion it didn’t work.

I had not used apm login before, yet when I logged in this time and created the repo I still get unauthorized.


#5

Is it possible to just get an admin to take it off?


#6

@thedaniel, can you help out here?


#7

Why can’t we just unpublish our packages without the hassle? This is just weird.

While you’re at it, can you please unpublish my acpp package, too? Thanks in advance, but please make it so one can just publish / unpublish / delete / etc. package from their profile, that’d be great.


#8

Couldn’t agree more