Unmet Git dependency


#1

Just tried to install autocomplete-plus and got the following error:

Installing “autocomplete-plus@2.0.11” failed.
Failed to install autocomplete-plus because Git was not found.

The autocomplete-plus package has module dependencies that cannot be installed without Git.

You need to install Git and add it to your path environment variable in order to install this package.

Run apm -v after installing Git to see what version has been detected.

Which Git is being referenced here. I have git installed on my machine, and running apm -v gives me the following:

➜ apm -v                                                                                                                                            
apm  0.134.0
npm  2.3.0
node 0.10.35
python 2.7.6
git 2.2.1

Any ideas?


#2

Do you have git in your PATH? what happens if you run git -v in your command line?


#3
git --version
git version 2.2.1

#4

I’m having the same issue with atom-beautify. The problem I believe is stemming from a git upgrade after atom was installed. I’m new to atom so I’m not sure where to look for potential configuration issues related to removing and reinstalling git.

I’ve confirmed Git is available and up to date in my terminal sessions. So I’m shrugging here.

> apm -v
apm  0.134.0
npm  2.3.0
node 0.10.35
python 2.7.6
git 2.2.1
> git --version
git version 2.2.1

Any ideas are appreciated.


#5

Could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Have you tried installing through the Settings View or at the command line?
  • If you have tried installing through the Settings View, can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#6

OSX Yosemite: Version 10.10.1
Atom: Version 0.177.0 (0.177.0)

I’ve been attempting to install through Settings view.

–safe mode did the trick.


#7

Interesting … so some third-party package must be messing with your PATH.


#8

Yeah, what’s odd though is I have a base install of atom. This is the first package I’m installing, other than the ones that ship with atom.


#9

Actually, now that I’m thinking about it … I suspect what you’re running into @mvandiest is the classic issue of the PATH is different when you execute Atom from the command line and from the icon. (This is not an issue with Atom, but with OS X.) When you run apm --version or atom --safe, you get the PATH that can find Git. But when you run from the icon, you get the PATH that doesn’t include Git.


#10

Thanks @leedohm, I was thinking it was a PATH issue at first since I had upgraded git which requires removal of older git version. My git install path changed between those installs.

I’ll look into the OSX PATH issue.

Thanks!


#11

Thanks guys.

I was having exactly the same issue and found the only way that I could update packages was with atom --safe.

It’s not a major deal but does anyone know how to fix that PATH issue?

I followed http://apple.stackexchange.com/questions/51677/how-to-set-path-for-finder-launched-applications/79845#79845 but no dice.

Cheers.


#12

If the problem goes away with atom --safe then one of your installed packages is causing the problem. You should consider using the package package-cop to find out which package is causing your problem.


#13

package-cop won’t help as the issue is to do with the PATH environment variable on OS X as per Unmet Git dependency

Nothing to do with bad packages.


#14

Ah. You specifically said atom --safe. So using just atom will also fix the problem.


#15

Quick update:

This fixed the PATH issue for me: http://apple.stackexchange.com/a/106814

So I can now update packages from Atom launched from the dock.

Basically create a plist file with your PATH in it.

Cheers.


#16

How do you install git on your machine? I’m having the same issue and have no idea where to find this installable git. Can someone send me a link and maybe instructions on where to go from there?