Uninstall problem


#1

Setting up Atom on my Office PC, at home I haven’t experience these issues. There are two packages which I have been trying to remove “remote-edit” and “remote-sync” due to them somehow not being installed correctly.

Package folders are not visible in C:\Users\user.atom\packages

I have pressed “Uninstall” on both of these from in Atom (Tried enable too, but to no avail)

In node.js I have used “apm uninstall remote-sync” and “apm uninstall remote-edit” and again, these are still here.

Restarted a considerable amount of times, tried re-installing them via “apm install remote-edit”


#2

Are the packages in C:\Users\user\.atom\dev\packages?


#3

Also, do you, or did you, use a custom path using the ATOM_HOME variable at some point?


#4

Hi, I have just checked no folder “dev” exists in “C:\Users\user.atom”


#5

Fresh installation, never used Atom on the machine so no path variables have been modified, only things done are installation of packages.


#6

Have you completely exited all instances of Atom? If there are no directories in C:\Users\user\.atom\packages there isn’t anywhere else it is going to load third-party packages from really.


#7

Yes, it is strange, I’ve restarted the machine also


#8

It looks like you’ve installed Nuclide. Perhaps they add some other locations where packages can be installed? Maybe @bolinfest can shed some light?


#9

Only way I managed to fix this was delete “.atom” and uninstall Atom itself and do a completely fresh install and it seems to be working as expected now.


#10

Did you install Nuclide again though, after your fresh installation?


#11

Nuclide was never installed.