Uncaught TypeError: Cannot read property 'tokenAtBufferColumn' of undefined


#1

Hi, I am getting error Uncaught TypeError: Cannot read property ‘tokenAtBufferColumn’ of undefined.

Steps to reproduce:

  1. Open Atom with atom --safe.
  2. Create new lines.
  3. Select them.
  4. Use command Editor: Split Selections Into lines.
  5. Write something.
  6. Press escape to cancel multi selection.
  7. Run Core:Undo.
  8. Run Core:Undo for second time.

Gif with example:

Whole stack trace.

I have tried this on Windows 7 Pro and Ubuntu 14.04 both running Atom 0.152. I might try this on Windows 8 if this helps.


#2

I just tried it on Atom v0.153.0-1268357 on Mac OS X 10.10.1 and was unable to reproduce the issue. When the DDOS attack calms down, I may try downloading v0.152.0 and see if that works.

BTW, did you build v0.152.0? Or did you install it from a binary?


#3

I have tried it also on second machine on Windows 8 and same problem. Atoms on windows were installed using chocolatey and on Ubuntu I think I downloaded package directly from Atom.


#4

I’d say add your information to


#5

Shouldn’t I rather open new issue , this one seems to be slightly different.


#6

You could open a new issue, but from what I saw … the root cause of the two issues is the same. If you open a new issue, you should definitely link to the one I mentioned.