Uncaught Exception: Error The specified procedure could not be found


#1

So I’m writing a node plugin. I had it working in Electron perfectly and then I decided to rename what it was called as I had just named it “addon”.

Now I get the error App threw an error when running [Error: The specified procedure could not be found.] in the console window and the error above in the title in a dialog.

Here’s what I have already done:

Followed instructions here: https://github.com/atom/electron/blob/master/docs/tutorial/using-native-node-modules.md

Renamed the target_name in binding.gyp to the new name.

Added correct NODE_MODULE() in the C++ file (NODE_MODULE(jripc, init))

Changed the require in the js to point to the right jripc.node file which does exist and compiled just fine using:

node-gyp build --target=0.29.1 --arch=x64 --dist-url=https://atom.io/download/atom-shell

Note: ALL this stuff worked when it was called “addon” I tried renaming it back to addon but that didn’t change anything.

Can someone please help me?


#2

Hi,

I have the same issue, did you find a solution ?


#3

Yes… my problem was that I was using the wrong target. You have to use the exact --target as what you download. The instructions on the website should be a bit more clear on that (though it does make sense).

I’m not sure why it went from working to not working but I have it compiling and running now.