Unable to update packages


#1

Trying to check for updates within Atom but all I get is “Request for package information failed: connect ETIMEDOUT” errors.

I can install new packages, but checking for updates for the last couple of days has given me the above error.

Any clues as to the problem?


#2

I’ve also had this issue a few times. Updating from within Atom gave me the error, but updating from the command line with apm update worked just fine.


#3

Fails with amp update as well, but this does appear to be an issue with our internal work network. All seems fine when I try and update from home :frowning:

Guess we’ll need to put a support request in with the IT guys…


#4

Have you followed the proxy instructions here?


#5

I’ve also been seeing this same error recently, both within Atom and on the command line (same “ETIMEDOUT” message in both cases). Not behind a separate firewall. Nothing else over the network seems to be having problems loading/connecting at the same time as checking for updates, so slightly confused as to the cause. :confused:


#6

We don’t use a proxy, but according to our IT guys it appears to be the Sophos firewall that’s blocking it. They still haven’t fixed it yet mind you…