Unable to update emmet due to self signed certificate


#1

As stated in the subject, I can’t update it. The elixir language I could update however.

npm http GET https://registry.npmjs.org/season
npm http GET https://registry.npmjs.org/season
npm http GET https://registry.npmjs.org/season
npm ERR! Error: SELF_SIGNED_CERT_IN_CHAIN
npm ERR!     at TLSSocket.<anonymous> (_tls_wrap.js:777:36)
npm ERR!     at TLSSocket.EventEmitter.emit (events.js:98:17)
npm ERR!     at TLSSocket._finishInit (_tls_wrap.js:337:8)
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/isaacs/npm/issues>

npm ERR! System Darwin 13.1.0
npm ERR! command "/Applications/Atom.app/Contents/Frameworks/Atom Helper.app/Contents/MacOS/Atom Helper" "/Applications/Atom.app/Contents/Resources/app/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--userconfig" "/Applications/Atom.app/Contents/Resources/app/node_modules/atom-package-manager/.apmrc" "install" "/var/folders/3y/lrmj3jm96x11lzksy8yjp5780000gn/T/d-114128-4652-1ogu9s8/package.tgz" "--target=0.11.10" "--arch=x64"
npm ERR! cwd /private/var/folders/3y/lrmj3jm96x11lzksy8yjp5780000gn/T/apm-install-dir-114128-4652-9gtyue
npm ERR! node -v v0.11.10
npm ERR! npm -v 1.3.18
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /private/var/folders/3y/lrmj3jm96x11lzksy8yjp5780000gn/T/apm-install-dir-114128-4652-9gtyue/npm-debug.log
npm ERR! not ok code 0

Apm/npm issue installing packages
#2

Just had the same issue. Bumping npm to 1.4.3 in /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/package.json and doing an npm install helped.


#3

+1 works for me as well


#4

Sorry about this, it is due to http://blog.npmjs.org/post/78085451721/npms-self-signed-certificate-is-no-more

I’m about to publish a 0.62.0 release with a fix for it that upgrades npm to 1.4.4


#5

@kevinsawicki thanks for that…


#6

0.62.0 has been released, expect your Atom to update in the next hour.


#7

@kevinsawicki not sure if it is related but I still seeing some errors trying to install packages with Atom 0.62.0, OS X 10.9.2

apm install atom-darkmatter-ui

Unable to download https://www.atom.io/api/packages/atom-darkmatter-ui/versions/1.1.0/tarball: 400 Bad Request Repository inaccessible

#8

Hmm, that appears to be a different issue related to how atom.io integrates with the GitHub API.

Does it happen every time or only intermittently?


#9

@kevinsawicki only with some packages.

This works fine

apm install css-color-highlighting