Unable to unpublish packages


#1

After having some errors with publishing a package I delete and recreate the repo, and do the same for the apm packages, however, I get the error:
Unpublishing failed: Unauthorized
I would like to delete all of my current packages (only two which are supposed to be the same one).

I tried to recreate the GitHub repo and retry, it failed.
And I also tried to re-login. also failed.

Any ideas?


#2

When you delete the repo before you unpublish the package, apm has no way of knowing who the authoritative party is. @leedohm has the ability to help you out, but you should share the precise packages you’d like deleted.


#3

Thank you for the fast response.
@leedohm The two packages i want to delete are:
https://atom.io/packages/atom-x-ui
https://atom.io/packages/x-theme


#4

Do you want to republish either of these repositories?


#5

Sorry for the late reply, I thought I will get an email notification…
Yes, I will republish one of them but as a theme.
And Thanks for the help!


#6

Which name do you want to republish under? I have to go through extra steps to free up the name.


#7

“x-theme”.
and thanks!


#8

Done. And you’re welcome :grinning: