Unable to unpublish atomic-elixir package


#1

I interrupted apm publish and the package seems to be left in an inconsistent state (e.g. missing description).

I tried apm unpublish but I get Unpublishing failed: Unauthorized. I also tried apm login already.

Currently, my repo is already bumped to v0.1.0 and I can’t publish nor unpublished.


#2

If the v0.1.0 tag exists both locally and remotely and you haven’t deleted the GitHub repo since you first attempted publishing the package, you should be able to use the apm publish --tag v0.1.0 command to finish the publishing process.


#3

Great suggestion but apm publish --tag v0.1.0 still failed.

I’ve confirmed the v0.1.0 tag exists both locally and remotely. Here’s the repo for sanity check.

$ apm publish --tag v0.1.0
Publishing atomic-elixir@v0.1.0 ✗
Creating new version failed: Git tag not found

#4

I’ve deleted the package so that you can try publishing again.

I see that you’re creating a fork of the original package. You may want to see if the original author could make you a collaborator on the original so that you can publish updates. This prevents the package system from being cluttered with two nearly identical packages and means that people don’t have to manually uninstall the original and install yours.