Unable to type after pressing Space key


#1

Hello,

I have a fresh Windows 8.1 Pro installation. I installed Atom. I created a shortcut on my desktop. I run the app as an administrator. When the app launches, a blank tab is shown. I started to type “Hello, World”. Unfortunately, I only got as far as "Hello, ".

Anytime I press the Space key, the text editor will not accept any new text until I tab to another app and tab back to it. Very strange behavior.

Thank you


#2

Open the “key-binding-resolver” package (ctrl and .[period]). Type a space and let us know what command gets run. Maybe autocomplete is getting opened (which is ctrl and space by default).


#3

When I type space, I see “Key Binding Resolver: space”. I do not see autocomplete being mentioned in any way.


#4

I had the same/similar issue on OS X as of atom v0.146.0 due to using the new shadow DOM components. Whenever I would insert any character (including space) by typing, I could not input more characters by typing until I unfocused then refocused the window. All was fixed by disabling the shadow DOM in the settings.


#5

Also, try disabling “autocomplete-plus” and restarting Atom.


#6

Thank you for your response. I disabled the Shadow DOM and things worked again. Thank you for your help!