Unable to quit Atom Editor using macOS shortcut CMD Q



I am a brand new Atom user and I have stumpled upon my first issue. I am unable to quit Atom Editor using macOS keyboard shortcut and also via menubar. Is this a known issue? I am running Mac Sierra 10.12.6

Steps to reproduce

  1. Open a blank document in Atom
  2. Using keyboard shortcut: press Command Q

-----> Atom application remains opened

  1. Go to menubar > Atom

-----> Atom application remains opened


Create a new macOS keyboard shortcut for Atom. This way I able to press Command Q, also completeley quit Atom via menubar.


You can find out what command is being executed by Atom when you press a particular set of keys, using the Keybinding Resolver. If you remove your new shortcut and try cmd-q with the Resolver panel open, then screenshot that panel, there’s a solid chance that I can tell you what’s going on.


DamnedScholar: Thank you for pointing me in the right direction. I was able to resolved the issue by removing the macOS keyboard. Cmd-q shows up the in the Resolver panel.


Unfortunately I have to get back to my orginal question. Today I am not able to Quit Atom Editor again. Same issue as described above. Here is a screenshot from the Keybindungs window. What can I do?


Please look at the Keybinding Resolver as I have described previously and screenshot it.


When I hit CMD-q, Atom Editor quits as expected. This is really strange. Sometimes, Atom won’t close randomly via keyboard shortcut


Next time it doesn’t quit for you, take another look at the Keybinding Resolver, screenshot it, and think back to everything you’ve done since the last time that Atom did quit for you.


@DamnedScholar: It happened again. I have attached a screenshot. No changes have been made to Atom Preferences. I have simply open and close a css file. Any ideas? Thanks in advanced for your help.



I’m not sure what’s wrong. That looks the way it should look.


Thank you for your reply.

Okay, I ended up creating my own macOS keyboard shortcut, instead. Now, Atom Editor quits as expected.


I’m having similar issues, MacOS High Sierra 10.13.5, Atom version 1.27.2. I checked keybinding resolver and get the exact same application:quit as howdytom


It’s still a bug, but does the fix @howdytom mentions work?


The workaround from above works perfectly fine. :grinning:


Confirming issue, although @howdytom’s workaround does not work on my end. I’ve applied a custom keymap for quitting but nothing happens.


@ojtibi -
To further the conversation for others to follow up on…
What happens if you trigger application:quit from the command pallet?

I am expecting that this command is not working properly. To me it seems that the original key binding is doing what it is suppose to be doing - the white item in your picture.

I only work on MS Windows; the command does work as expected on my system.


Today, it happened again. Unfortunately my workaround doesn’t work anymore.

This is such a annoying bug. Where can I report this bug report?


The Atom repo.


I’m having the same problem with quitting Atom. Not only Cmd+Q doesn’t work, but also if I’m trying to quit using Atom -> Quit command in application menu — it is just ignored, the app stays up as is. So the problem seems to be not in keyboard shortcut, but with quit command.
macOS Sierra 10.12.6, Atom 1.28.2


Same error like @artoix wrote above me

No response on CMD+Q and no response if i close via Atom Quit and additionally no response on quit with mac-os-launcher

Atom: 1.30.0 x64
Mac: macOS HighSierra v10.13.6


I, too, am having this problem intermittently on MacOS (10.12.6).

⌘-q works sometimes, but doesn’t work other times. It often happens after my computer wakes from sleeping, but not always, and it has happened other times occasionally too (when not waking from sleep). ⌘-q the quit command shown in my key bindings, so it’s in there. Also, when ⌘-q doesn’t work, Application: quit from the command pallet doesn’t work either, nor does going to Atom > Quit. I have to force quit the application.

This is with Atom 1.30.0.