Unable to pull with atom / bitbucket


#1

Hello,
I use atom with bitbucket for some projects, but today it is not working with new projects, but still working with old projects…
I made a video of the current problem to explain it better :


When it crashs and I close atom, it remove the file…

It seems working when using atom safe mode, also working when I use atom on linux, but not working with windows 10…
I also tried to use the git bash on windows to make pull request but not working aswell… (same error)
I tried all the stuffs i found on the atom debug tutorial, and forums like https://github.com/jacogr/atom-git-control/issues/145
https://github.com/atom/atom/issues/7137
(and many others…)
I don’t know what to do, tried to change directory permissions, made an other bitbucket directory, changed the permission on bitbucket, file name, file extensions…

I’m using atom 1.26
and Windows 10

Hope someone can help me
Thank you!


#2

Then the problem is a community package you have installed. You will need to narrow it down to which one it is before anyone can help.


#3

Thanks for reply,
disabled all the community package, also made the atom 1.26.1 update, and no change… now pull doesn’t return any error, and not working anymore when using safemode… I got atom installed on 3 different windows computer and same error…


#4

From your video I see you’re getting permission denied errors - we have an open issue for file locking problems as of 1.25 here:

Curious if this is the same issue - can you confirm if you install 1.24.1 if you still get the same error?


#5

thanks for reply,
Installed atom 1.24.1 on 2 different computer, made a few exchanges commit pull push… and didn’t get any error.
It seems working perfectly with 1.24.1… No idea about what to do, tried many things that i found on forums for current version.


#6

Thanks for confirming - I think you are running into the issue I mentioned since you’re not getting the same error in 1.24.1. The issue is still open so you may want to stick to 1.24.1 until it’s fixed. and you can subscribe to the issue for updates.


#7

Issue solved thank to the solution given at https://github.com/atom/atom/issues/17013
(create a folder at C:\Users{user}.atom\ called recovery)

thank you guys for helping !