Unable to Install Packages due to GIT not found, despite installed


#1

I have installed, uninstalled, and reinstalled both ATOM, and GIT, but continue to get on both my desktop and laptop the same error when installing sass-watcher or any package.

The error is for this package:

Failed
Failed to install sass-watch because Git was not found.

The sass-watch package has module dependencies that cannot be installed without Git.

You need to install Git and add it to your path environment variable in order to install this package

You can install Git by downloading, installing, and launching GitHub for Windows: URL

Run apm -v after installing Git to see what version has been detected.

I ran apm -v and Git is there. So is python and Visual. I get the same issue on my Surface Pro 3, which is new and has a fresh install of atom and no packages, but git, and node.js are installed. I verified my PATH and all looks good, I don’t see any issues with that. I don’t know if I’m missing something?


#2

How are you attempting to install the package? In the Settings View? Or at the command line? Can you paste the output of apm -v?


#3

I did both install through atom, in safe mode, normal mode, and admin mode. I tried to install via command line in admin mode after directing to the packages folder and using apm install sass-watcher

My apm -v gives me the following:

apm 1.4.0
npm 2.13.3
node 0.10.40
python
git
visual studio 2013

#4

It appears that apm is not detecting Git. It should normally specify a version number like this:

apm  1.5.0
npm  2.13.3
node 0.10.40
python 2.7.10
git 2.6.3

Are you certain the git binary is on your PATH?


#5

C:\Ruby22\bin;C:\Users\nick\.dnx\bin;C:\Users\nick\AppData\Local\atom\bin;C:\Users\nick\AppData\Roaming\npm;D:\Microsoft VS Code\bin;C:\Users\nick\AppData\Local\Programs\Git\cmd

That’s my PATH Variable, set up specifically by the Git installer.


#6

What happens when you type git --version at the command line? Have you tried installing GitHub for Windows?


#7

I get the following

git version 2.6.3.windows.1

I don’t think the last part should be there the windows.1


#8

Unfortunately, I haven’t tried to set up Atom on Windows yet, so I’m not sure what’s going wrong.

@raelyard, do you have any ideas?


#9

Thing was, it was working up until today. I meant that I just recently fresh installed on my second Windows machine.


#10

@kupoback How did you install git? Installing git either directly via Chocolatey or via GitHub for Windows, I’d expect (what I see on my machine) from git --version:
git version 1.9.5.msysgit.1

I’d recommend using Chocolatey to install git.
https://chocolatey.org/packages/git


#11

I had problems installing packages as well, but the error message did not point me in the correct direction. My problem was a corporate proxy (which had not given me problems up til last week)

Maybe something to investigate?


#12

For some reason I got no notifications on this.

I installed Git for Windows directly via download. I will try to go through and uninstall Git and clean up any remaining files.

However, it’s not an Atom issue it seems, so I will bring this elsewhere.

UPDATE Uninstalled and reinstalled, when I check, I get git when checking versions.