Unable to install package terminal-plus


#1

this is the log:
> pty.js@0.3.0 install /private/var/folders/z2/qhlwbs6d4c16tz0bt0smf3jc0000gn/T/apm-install-dir-1151030-17076-1nwhu5m/node_modules/terminal-plus/node_modules/pty.js
> (node-gyp rebuild 2> builderror.log) || (exit 0)

npm ERR! Darwin 15.2.0
npm ERR! argv "/Applications/Atom.app/Contents/Resources/app/apm/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Users/LeanderK/.atom/.apm/.apmrc" "--userconfig" "/Users/LeanderK/.atom/.apmrc" "install" "/private/var/folders/z2/qhlwbs6d4c16tz0bt0smf3jc0000gn/T/d-1151030-17076-11k12nq/package.tgz" "--target=0.34.0" "--arch=x64"
npm ERR! node v0.10.40
npm ERR! npm  v2.13.3
npm ERR! file sh
npm ERR! code ELIFECYCLE
npm ERR! errno ENOENT
npm ERR! syscall spawn

npm ERR! pty.js@0.3.0 install: `(node-gyp rebuild 2> builderror.log) || (exit 0)`
npm ERR! spawn ENOENT
npm ERR! 
npm ERR! Failed at the pty.js@0.3.0 install script '(node-gyp rebuild 2> builderror.log) || (exit 0)'.
npm ERR! This is most likely a problem with the pty.js package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     (node-gyp rebuild 2> builderror.log) || (exit 0)
npm ERR! You can get their info via:
npm ERR!     npm owner ls pty.js
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /private/var/folders/z2/qhlwbs6d4c16tz0bt0smf3jc0000gn/T/apm-install-dir-1151030-17076-1nwhu5m/npm-debug.log

the last file is not existing. There is no folder: apm-install-dir-1151030-17076-1nwhu5m.

The editor of the package said there should be no error on his side.


#2

This looks related: