Unable to install on Windows 7


#1

Have tried the stable installer (1.5.3), previous installers back to 1.4.3, and the beta. Have also tried deleting the …\AppData\Local\atom folder, restarting the machine and retrying the installer to no avail. Anyone have any suggestions?

2016-02-15 19:14:05> Program: Starting Squirrel Updater: --install .
2016-02-15 19:14:05> Program: Starting install, writing to C:\Users\Scott\AppData\Local\SquirrelTemp
2016-02-15 19:14:05> Program: About to install to: C:\Users\Scott\AppData\Local\atom
2016-02-15 19:14:05> Program: Install path C:\Users\Scott\AppData\Local\atom already exists, burning it to the ground
2016-02-15 19:14:05> CheckForUpdateImpl: Failed to load local releases, starting from scratch: System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Users\Scott\AppData\Local\atom\packages\RELEASES'.
2016-02-15 19:14:05> CheckForUpdateImpl: Reading RELEASES file from C:\Users\Scott\AppData\Local\SquirrelTemp
2016-02-15 19:14:05> CheckForUpdateImpl: First run or local directory is corrupt, starting from scratch
2016-02-15 19:14:05> ApplyReleasesImpl: Writing files to app directory: C:\Users\Scott\AppData\Local\atom\app-1.6.0-beta3
2016-02-15 19:14:07> IEnableLogger: Failed to install package to app dir: System.IO.IOException: The process cannot access the file 'C:\Users\Scott\AppData\Local\atom\app-1.6.0-beta3\lib\net45\squirrel.exe' because it is being used by another process.
2016-02-15 19:14:07> Unhandled exception: System.AggregateException: One or more errors occurred. ---> System.IO.IOException: The process cannot access the file 'C:\Users\Scott\AppData\Local\atom\app-1.6.0-beta3\lib\net45\squirrel.exe' because it is being used by another process.
---> (Inner Exception #0) System.IO.IOException: The process cannot access the file 'C:\Users\Scott\AppData\Local\atom\app-1.6.0-beta3\lib\net45\squirrel.exe' because it is being used by another process.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

#2

If you have an anti-virus, temporarily disable it.

In my experience, McAfee will block it for sure.

I switched to Norton and it installs fine.


#3

That was the problem. Thanks!


#4

It might make sense to add this as a pinned topic about Windows or FAQ entry in the Documentation. It’s been showing up a lot lately.