Unable to install atom packages in windows 10


#1

I downloaded ATOM today, i wanted to install the package “platformio-ide-terminal” i tried installing it via two methods, one using settings->install package second using apm, both the installation process are not working, it is struck at the installation process for quiet a long long time when i try installing it using my College WiFi network and when i try to use My mobile network data as a hotspot to install the package it displays the following error:


#2

The error doesn’t seem to have been posted.


#3

error displayed: Unable to download https://www.atom.io/api/packages/platformio-ide-terminal/versions/2.8.4/tarball: connect ETIMEDOUT 52.1.117.85:443


#4

What happens if you use a non-mobile wifi other than your school’s network? Timeouts aren’t generally fixable from the user’s end unless the network node timing out is your modem or router.


#6

if i use my mobile network data i get the following error:

C:\Users\Rohit\AppData\Local\atom\app-1.29.0\resources\app\apm\lib\install.js:313
          if (body.releases.latest) {
                           ^

TypeError: Cannot read property 'latest' of undefined
    at C:\Users\Rohit\AppData\Local\atom\app-1.29.0\resources\app\apm\lib\install.js:313:28
    at Request._callback (C:\Users\Rohit\AppData\Local\atom\app-1.29.0\resources\app\apm\lib\request.js:56:22)
    at Request.self.callback (C:\Users\Rohit\AppData\Local\atom\app-1.29.0\resources\app\apm\node_modules\request\request.js:185:22)
    at emitTwo (events.js:106:13)
    at Request.emit (events.js:191:7)
    at Request.<anonymous> (C:\Users\Rohit\AppData\Local\atom\app-1.29.0\resources\app\apm\node_modules\request\request.js:1157:10)
    at emitOne (events.js:96:13)
    at Request.emit (events.js:188:7)
    at IncomingMessage.<anonymous> (C:\Users\Rohit\AppData\Local\atom\app-1.29.0\resources\app\apm\node_modules\request\request.js:1079:12)
    at IncomingMessage.g (events.js:291:16)

#7

now when i try again today to download the package(in Atom->Settings->Install Package) using the college WiFi i get this error:

Installing “platformio-ide-terminal@2.8.4” failed.Hide output…

gyp info it worked if it ends with ok
gyp info using node-gyp@3.4.0
gyp info using node@6.9.5 | win32 | x64
gyp http GET https://atom.io/download/electron/v2.0.5/iojs-v2.0.5.tar.gz
gyp http 200 https://atom.io/download/electron/v2.0.5/iojs-v2.0.5.tar.gz
gyp http GET https://atom.io/download/electron/v2.0.5/SHASUMS256.txt
gyp http GET https://atom.io/download/electron/v2.0.5/win-x64/iojs.lib
gyp http GET https://atom.io/download/electron/v2.0.5/win-x86/iojs.lib
gyp http 200 https://atom.io/download/electron/v2.0.5/win-x64/iojs.lib
gyp http 200 https://atom.io/download/electron/v2.0.5/win-x86/iojs.lib
gyp http 200 https://atom.io/download/electron/v2.0.5/SHASUMS256.txt
gyp WARN install got an error, rolling back install
gyp ERR! install error 
gyp ERR! stack Error: win-x64/iojs.lib local checksum 751e2052b967e076edd6a77bdc8eaa77e1f6d6f16dca75587605508a4e20245e not match remote b3a25a4f8791287dec702891dc5eb76f6c62d7a08daa60b5e177801ab6650d59
gyp ERR! stack     at deref (C:\Users\Rohit\AppData\Local\atom\app-1.29.0\resources\app\apm\node_modules\node-gyp\lib\install.js:266:20)
gyp ERR! stack     at Request.<anonymous> (C:\Users\Rohit\AppData\Local\atom\app-1.29.0\resources\app\apm\node_modules\node-gyp\lib\install.js:354:24)
gyp ERR! stack     at emitOne (events.js:101:20)
gyp ERR! stack     at Request.emit (events.js:188:7)
gyp ERR! stack     at IncomingMessage.<anonymous> (C:\Users\Rohit\AppData\Local\atom\app-1.29.0\resources\app\apm\node_modules\request\request.js:1079:12)
gyp ERR! stack     at IncomingMessage.g (events.js:291:16)
gyp ERR! stack     at emitNone (events.js:91:20)
gyp ERR! stack     at IncomingMessage.emit (events.js:185:7)
gyp ERR! stack     at endReadableNT (_stream_readable.js:974:12)
gyp ERR! stack     at _combinedTickCallback (internal/process/next_tick.js:74:11)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command "C:\\Users\\Rohit\\AppData\\Local\\atom\\app-1.29.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\Rohit\\AppData\\Local\\atom\\app-1.29.0\\resources\\app\\apm\\node_modules\\node-gyp\\bin\\node-gyp.js" "install" "--runtime=electron" "--target=2.0.5" "--dist-url=https://atom.io/download/electron" "--arch=x64" "--ensure"
gyp ERR! cwd C:\Users\Rohit\.atom
gyp ERR! node -v v6.9.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

#8

Does this happen with other packages?