Unable to find command: python


#1

hi
i am trying to run python code and keep getting the same error:

Are you sure PATH is configured correctly?

ENV PATH: C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Microsoft SQL Server\Client SDK\ODBC\110\Tools\Binn;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn;C:\Program Files (x86)\Microsoft SQL Server\120\DTS\Binn;C:\Users\Administrator\AppData\Local\atom\app-1.15.0;C:\Program Files (x86)\Nmap

Error: spawn python ENOENT
at exports._errnoException (util.js:1026:11)
at Process.ChildProcess._handle.onexit (internal/child_process.js:193:32)
at onErrorNT (internal/child_process.js:359:16)
at _combinedTickCallback (internal/process/next_tick.js:74:11)
at process._tickCallback (internal/process/next_tick.js:98:9)
Running: python (cwd=C:\Users\Administrator\AppData\Local\atom\app-1.15.0\alex.py pid=undefined).

what is that?
i found a shord guide to fix it but i cant understand it:

tnx


#2

Do you have Python installed? If so, where is it?


#3

i need to install external python ide to use python on atom?
sounds weird :confused:

tnx


#4

No, you need to install the Python interpreter itself. Atom does not come with any compilers or interpreters, and generic packages like atom-runner certainly aren’t going to presume to download all of the executables that they could potentially be used with.


#5

tnx for explaining :slight_smile:
so i installed the interpreter it self and it remains the same.
the python it self installed in C:\Python27.
where do i need to change the path?

tnx


#6

#7

What’s the output of the PATH variable now?

This is a guess, but if you haven’t closed Atom since you installed Python, it might not have picked up the new PATH.


#8

I am having the same issue and can’t figure it out, even with what was said in this thread.


#9

The Python installer for Windows makes it really easy to add the interpreter to the PATH. Just make sure to select the checkbox at the bottom of the screen (afaik, the Python 2 installer has the same option!)

00


#10

If you tell us more about your environment, we can help with that. You just have to answer the same set of questions.


#11

I figured it out. I had to uninstall and custom reinstall Atom, Python, and Anaconda Navigator a few times because Anaconda Navigator had been set as the default environment for Python on my computer.


#12

Thank you very much! As a newbie to Atom this was sending me round in circles. Love your work!