"Unable to find a valid app" error Windows 10


#1

I was working on my code and I accidentally moved the file I was working on to another pane, and an error came up briefly before Atom crashed. Now when I try to start the editor I just get an error:

All my project files are in exactly the same directories they were in before this error. From what I was able to read in the first error I got (which disappeared before I could get a screenshot), it said something about the pane not existing or something like that, it was only up for about a second or two so I didn’t really get a good look I’m afraid.


#2

What happens when you rename the .atom folder in your user directory? If that doesn’t fix it, you might try reinstalling. If that does fix it, then there’s some corrupted data in the storage and you will want to move your packages and config files over to the new folder.


#3

Renaming the .atom folder did nothing, and the uninstall function resulted in the same error as before but manually deleting all the files and then reinstalling did work, thanks.


#4

I was having this same error when right clicking a file or folder in windows explorer and choosing open with atom. I found that the corresponding entries in the registry were pointing to an older version 1.17.0. Updated it in the registry to 1.17.2 and it works now

HKEY_CLASSES_ROOT\Directory\shell\Atom\command if you are administrator
HKEY_CURRENT_USER\Software\Classes\directory\shell\Atom\Command if you are a normal user

This might not have fixed @Mundane’s issue, but may help someone else who comes across this error


#5

Same issue. Tierneykev sent me on the right direction. My error was due to a recent automatic update of Atom. Here’s the step I took to correct the problem:

  • Go to Atom’s setting page
  • Go on the System tab
  • If you have the same problem as me, all checkbox will be unchecked due to that update. I’ve checked and unchecked them just to be sure that they would reset the registry.

It worked for me.


#6

Thanks @marc-andre.d I also had a botched automatic update to v1.19.0 and couldn’t open files or folders with the right click open in Windows. Just like you, all options were unchecked and I toggled them and quit Atom and then could open files with a right click.