Unable to auto-update from 0.181.0


#1

I have Atom 0.181.0 on my Windows 8 (x64) computer. I see on the Github repo’s releases page that the newest version is 0.199.0, but clicking “Check for updates” in the menu shows that no update is available.

Following Atom auto updater not working, I tried deleting those keys from the local storage, and restarted Atom, but now it says “version 0.179.0” in the menu instead of 0.181.0!

I do not think that this is related to the bug referenced at Atom isn't automatically updating

How can I get it to update properly?


#2

Did you install Atom via Chocolatey? If so, you might want to follow these instructions:

You can also always download the latest version from https://github.com/atom/atom/releases and install following the instructions there.


#3

No, I installed it using the new installer.

Here’s an update: I manually upgraded to 0.198.0 by downloading the ZIP version and copying it into the right location, then tried to use the auto updater to update to 0.199.0.

Here is the error I get in SquirrelSetup.log:

CheckForUpdateImpl: First run or local directory is corrupt, starting from scratch
FileDownloader: Downloading file: 
UpdateInfo: Couldn't get release notes for:atom-0.199.0-full.nupkg: System.Exception: Invalid 'ReleaseNotes' value in nuspec file at 'C:\Users\moshe\AppData\Local\atom\..\atom\packages\atom-0.199.0-full.nupkg'
   at Squirrel.ReleaseEntry.GetReleaseNotes(String packageDirectory)
   at Squirrel.UpdateInfo.<FetchReleaseNotes>b__2(ReleaseEntry x)

I tried deleting the nupkg file and letting it redownload, but I get the same error in the log file every time.


#4

Please file an Issue on https://github.com/atom/atom and include all this information. If you could post a link to the issue here, I would appreciate it.


#5

Link to issue: