Ubuntu's Bash for Windows 10 in Atom does not works


#1

Hi all ! :slight_smile:
I’m new on Atom and finded this IDE really exiting and very useful for me. But when I tried to use the Bash Terminal for Windows 10 inside Atom, with the package “Platformio IDE Terminal” it doesn’t works…
-Bash works normally from Windows itself.
-I can open PowerShell or CMD with Platformio, no problem (specifiying “C:\WINDOWS\System32\cmd.exe” in the shell path field makes CMD open instead of PowerShell)

But, when setting the shell path to “C:\WINDOWS\System32\bash.exe”, the terminal does not display anything… When using the “bash” command in cmd.exe itself, bash.exe is launched, but when I try to do the same command from cmd inside Atom, he says me that he can’t found bash… It seems that Atom don’t have permissions to run bash.exe… Quite strange…

I’m sorry if my English is bad, it’s not my native language


#2

So? Is there a solution for my problem??


#3

The bash exe is special and (as far as I can tell) not available for use outside of cmd.


#4

Unfortunately true… I tried to execute it from one of my personal programs who redirects a terminal output, and it doesn’t worked anymore…


#5

Maybe try the emulation of bash that comes with Git for Windows? Setting it as the default shell doesn’t work, but you can activate it from the PlatformIO terminal if you don’t mind having a new window.


#6

Thanks for this tip, I’ll take a look to this emulator now :slight_smile: