Ubuntu Bionic Beaver Breaks Fonts In Atom 1.23.3


#1

Ubuntu Bionic Beaver development branch 18.04 introduces artifacts into the fonts of Atom 1.23.3 (image below). Installing Atom 1.25.0-beta2 solves the font issue, but introduces other issues with performance and crashes. Does anyone know if there are specific file(s) I can replace in my Atom 1.23.3 installation that are included in the 1.25.0-beta2 release that will solve the font issue without having to run the beta edition of Atom or causing additional issues?

I am running an HP 15-ay039wm laptop that was shipped with Windows 10. I have been running LInux Ubuntu 17.10 and Atom 1.23.3 with no issues for a few weeks now.

The same font rendering issue appears in the Discord desktop client for Linux, but not in Google Chrome, GIMP, LibreOffice, Enpass, Dropbox, the Linux GUI or GNOME software.

01


Atom display problem in xubuntu 18.04
Atom fonts are messed up!
#2

Interestingly, the markdown-preview 0.159.18 package does not share the issue with font artifacts.
last_second


#3

I had the same problem & fixed it by opening Developer Tools > Console & executing:

document.body.style["transform"] = "scaleX(1.0000001)"

This does not persist so you need to run that command every time you open Atom - until they fix it.

I found the solution for Discord here & tweaked that for Atom.


#4

Thanks. I found similar solutions after others started noticing the problem, but in the end I went with downgrading libfreetype6. This does not seem to be most people’s chosen solution, but I have had zero issues with it, and it automatically fixes Atom, Discord, etc.

sudo add-apt-repository "deb http://us.archive.ubuntu.com/ubuntu/ artful-updates main"
sudo apt-get update
sudo apt-get install libfreetype6=2.8-0.2ubuntu2.1
sudo apt-mark hold libfreetype6

#5

Cheers for those instructions.

It’s definitely fixed the font issue in Atom. I’ll report back if I come across any issues.


#6

I had the same issue and solved by simpy uninstalling and reinstalling atom 1.27.1 from ubuntu software.


#7

Thank you. I am glad it has been sorted. It appears to be taken care of in Discord as well so I assume the issue with Electron or Chromium or whatever was at the bottom of it has been resolved. I removed the hold on libfreetype6 sudo apt-mark unhold libfreetype6 added the Atom repo (although I am sure you can install directly from Ubuntu as you did as well) and all is well. Official Atom Repo Instructions.