TypeError shown upon loading folder


#1

Greetings,

I’m still new to Atom and just started to know the environment. Because the environment is great.

Unfortunately, I recently came across an error upon loading my concerned directory.
Below is the error stack trace.

TypeError: Cannot call method 'pauseEvents' of undefined
  at DisplayBuffer.module.exports.DisplayBuffer.pauseMarkerObservers (/Applications/Atom.app/Contents/Resources/app/src/display-buffer.js:1030:30)
  at DisplayBuffer.module.exports.DisplayBuffer.emitChanged (/Applications/Atom.app/Contents/Resources/app/src/display-buffer.js:184:14)
  at DisplayBuffer.module.exports.DisplayBuffer.updateWrappedScreenLines (/Applications/Atom.app/Contents/Resources/app/src/display-buffer.js:198:19)
  at /Applications/Atom.app/Contents/Resources/app/src/display-buffer.js:111:24
  at /Applications/Atom.app/Contents/Resources/app/node_modules/emissary/lib/behavior.js:33:16
  at /Applications/Atom.app/Contents/Resources/app/node_modules/emissary/lib/emitter.js:133:30
  at Array.forEach (native)
  at Behavior.module.exports.Emitter.emit (/Applications/Atom.app/Contents/Resources/app/node_modules/emissary/lib/emitter.js:132:47)
  at Behavior.module.exports.Behavior.emit (/Applications/Atom.app/Contents/Resources/app/node_modules/emissary/lib/behavior.js:44:38)
  at Behavior.module.exports.Emitter.on (/Applications/Atom.app/Contents/Resources/app/node_modules/emissary/lib/emitter.js:71:14)
  at DisplayBuffer.module.exports.Subscriber.subscribeWith (/Applications/Atom.app/Contents/Resources/app/node_modules/emissary/lib/subscriber.js:28:32)
  at DisplayBuffer.module.exports.Subscriber.subscribe (/Applications/Atom.app/Contents/Resources/app/node_modules/emissary/lib/subscriber.js:63:21)
  at new DisplayBuffer (/Applications/Atom.app/Contents/Resources/app/src/display-buffer.js:108:12)
  at Function.module.exports.Serializable.deserialize (/Applications/Atom.app/Contents/Resources/app/node_modules/serializable/lib/serializable.js:72:22)
  at Editor.module.exports.Editor.deserializeParams (/Applications/Atom.app/Contents/Resources/app/src/editor.js:126:44)
  at Function.module.exports.Serializable.deserialize (/Applications/Atom.app/Contents/Resources/app/node_modules/serializable/lib/serializable.js:58:25)
  at DeserializerManager.module.exports.DeserializerManager.deserialize (/Applications/Atom.app/Contents/Resources/app/src/deserializer-manager.js:42:29)
  at /Applications/Atom.app/Contents/Resources/app/src/pane.js:86:35
  at Array.map (native)
  at Pane.module.exports.Pane.deserializeParams (/Applications/Atom.app/Contents/Resources/app/src/pane.js:85:36)
  at Function.module.exports.Serializable.deserialize (/Applications/Atom.app/Contents/Resources/app/node_modules/serializable/lib/serializable.js:58:25)
  at DeserializerManager.module.exports.DeserializerManager.deserialize (/Applications/Atom.app/Contents/Resources/app/src/deserializer-manager.js:42:29)
  at /Applications/Atom.app/Contents/Resources/app/src/pane-axis.js:49:35
  at Array.map (native)
  at PaneAxis.module.exports.PaneAxis.deserializeParams (/Applications/Atom.app/Contents/Resources/app/src/pane-axis.js:48:41)
  at Function.module.exports.Serializable.deserialize (/Applications/Atom.app/Contents/Resources/app/node_modules/serializable/lib/serializable.js:58:25)
  at DeserializerManager.module.exports.DeserializerManager.deserialize (/Applications/Atom.app/Contents/Resources/app/src/deserializer-manager.js:42:29)
  at PaneContainer.module.exports.PaneContainer.deserializeParams (/Applications/Atom.app/Contents/Resources/app/src/pane-container.js:47:40)
  at Function.module.exports.Serializable.deserialize (/Applications/Atom.app/Contents/Resources/app/node_modules/serializable/lib/serializable.js:58:25)
  at Workspace.module.exports.Workspace.deserializeParams (/Applications/Atom.app/Contents/Resources/app/src/workspace.js:70:44)
  at Function.module.exports.Serializable.deserialize (/Applications/Atom.app/Contents/Resources/app/node_modules/serializable/lib/serializable.js:58:25)
  at Atom.module.exports.Atom.deserializeWorkspaceView (/Applications/Atom.app/Contents/Resources/app/src/atom.js:309:42)
  at Atom.module.exports.Atom.deserializeEditorWindow (/Applications/Atom.app/Contents/Resources/app/src/atom.js:324:19)
  at Atom.module.exports.Atom.startEditorWindow (/Applications/Atom.app/Contents/Resources/app/src/atom.js:348:12)
  at Object.<anonymous> (/Applications/Atom.app/Contents/Resources/app/src/window-bootstrap.js:14:8)
  at Object.<anonymous> (/Applications/Atom.app/Contents/Resources/app/src/window-bootstrap.js:20:4)
  at Module._compile (module.js:455:26)
  at Object.Module._extensions..js (module.js:473:10)
  at Module.load (/Applications/Atom.app/Contents/Resources/app/node_modules/coffee-script/lib/coffee-script/register.js:45:36)
  at Function.Module._load (module.js:311:12)
  at Module.require (module.js:363:17)
  at require (module.js:379:17)
  at window.onload (file:///Applications/Atom.app/Contents/Resources/app/static/index.js:20:5)

How can this be resolved, I wanted to reuse Atom.
I’ve tried re-installing Atom yet the error still shows up upon opening the folder.


#2

What Atom version are you using?
Can you run atom --safe from command line? Is the error still there?


#3

I had the same issue. My Atom version is 0.100.0.
“atom --safe” was not working.

My solution was deleting all files in “~/.atom/storage”.

I hope this will be helpful.