Type cursor is missing if project is opened in Tree View


#1

If project is opened in Tree View, type cursor is not visible. If I start typing something, Enter the new path… window is opened. If I remove project from Tree View, I can type in editor.


#2

Thank god I’m not the only one.

I didn’t notice tho that removing the project temporary fixes it.

Have been having the same issues ever since updated to 1.17, tried also beta 1.18 release with no luck. Makes the editor unusable - so I switched to Visual Studio Code until it gets resolved.

Here is my packages.json:

[
	{
		"name": "MagicPython",
		"version": "1.0.10"
	},
	{
		"name": "about",
		"version": "1.7.6"
	},
	{
		"name": "archive-view",
		"version": "0.63.2"
	},
	{
		"name": "atom-alignment",
		"version": "0.13.0"
	},
	{
		"name": "atom-beautify",
		"version": "0.29.24"
	},
	{
		"name": "atom-dark-syntax",
		"version": "0.28.0",
		"theme": "syntax"
	},
	{
		"name": "atom-dark-ui",
		"version": "0.53.0",
		"theme": "ui"
	},
	{
		"name": "atom-jade",
		"version": "0.3.0"
	},
	{
		"name": "atom-light-syntax",
		"version": "0.29.0",
		"theme": "syntax"
	},
	{
		"name": "atom-light-ui",
		"version": "0.46.0",
		"theme": "ui"
	},
	{
		"name": "atom-monokai",
		"version": "0.10.9",
		"theme": "syntax"
	},
	{
		"name": "atom-ternjs",
		"version": "0.18.3"
	},
	{
		"name": "auto-detect-indentation",
		"version": "1.3.0"
	},
	{
		"name": "autoclose-html",
		"version": "0.23.0"
	},
	{
		"name": "autocomplete-atom-api",
		"version": "0.10.1"
	},
	{
		"name": "autocomplete-css",
		"version": "0.16.1"
	},
	{
		"name": "autocomplete-glsl",
		"version": "0.2.3"
	},
	{
		"name": "autocomplete-html",
		"version": "0.7.3"
	},
	{
		"name": "autocomplete-modules",
		"version": "1.6.10"
	},
	{
		"name": "autocomplete-plus",
		"version": "2.35.3"
	},
	{
		"name": "autocomplete-snippets",
		"version": "1.11.0"
	},
	{
		"name": "autoflow",
		"version": "0.29.0"
	},
	{
		"name": "autosave",
		"version": "0.24.2"
	},
	{
		"name": "background-tips",
		"version": "0.27.0"
	},
	{
		"name": "base16-tomorrow-dark-theme",
		"version": "1.5.0",
		"theme": "syntax"
	},
	{
		"name": "base16-tomorrow-light-theme",
		"version": "1.5.0",
		"theme": "syntax"
	},
	{
		"name": "bookmarks",
		"version": "0.44.3"
	},
	{
		"name": "bracket-matcher",
		"version": "0.85.5"
	},
	{
		"name": "busy-signal",
		"version": "1.4.1"
	},
	{
		"name": "color-picker",
		"version": "2.2.5"
	},
	{
		"name": "command-palette",
		"version": "0.40.4"
	},
	{
		"name": "custom-title",
		"version": "1.0.1"
	},
	{
		"name": "dalek",
		"version": "0.2.1"
	},
	{
		"name": "deprecation-cop",
		"version": "0.56.7"
	},
	{
		"name": "dev-live-reload",
		"version": "0.47.1"
	},
	{
		"name": "docblockr",
		"version": "0.10.3"
	},
	{
		"name": "double-tag",
		"version": "0.8.0"
	},
	{
		"name": "editorconfig",
		"version": "2.2.2"
	},
	{
		"name": "emmet",
		"version": "2.4.3"
	},
	{
		"name": "encoding-selector",
		"version": "0.23.3"
	},
	{
		"name": "exception-reporting",
		"version": "0.41.3"
	},
	{
		"name": "expand-region",
		"version": "0.3.0"
	},
	{
		"name": "file-icons",
		"version": "2.1.6"
	},
	{
		"name": "filesize",
		"version": "3.0.0"
	},
	{
		"name": "find-and-replace",
		"version": "0.207.6"
	},
	{
		"name": "fuzzy-finder",
		"version": "1.5.6"
	},
	{
		"name": "git-diff",
		"version": "1.3.5"
	},
	{
		"name": "git-plus",
		"version": "7.8.1"
	},
	{
		"name": "go-to-line",
		"version": "0.32.0"
	},
	{
		"name": "grammar-selector",
		"version": "0.49.4"
	},
	{
		"name": "highlight-line",
		"version": "0.12.0"
	},
	{
		"name": "highlight-selected",
		"version": "0.13.1"
	},
	{
		"name": "image-view",
		"version": "0.61.2"
	},
	{
		"name": "incompatible-packages",
		"version": "0.27.3"
	},
	{
		"name": "indent-guide-improved",
		"version": "1.4.12"
	},
	{
		"name": "intentions",
		"version": "1.1.2"
	},
	{
		"name": "keybinding-resolver",
		"version": "0.38.0"
	},
	{
		"name": "language-babel",
		"version": "2.61.0"
	},
	{
		"name": "language-blade",
		"version": "0.30.0"
	},
	{
		"name": "language-c",
		"version": "0.57.0"
	},
	{
		"name": "language-clojure",
		"version": "0.22.2"
	},
	{
		"name": "language-coffee-script",
		"version": "0.48.6"
	},
	{
		"name": "language-csharp",
		"version": "0.14.2"
	},
	{
		"name": "language-css",
		"version": "0.42.2"
	},
	{
		"name": "language-gfm",
		"version": "0.88.1"
	},
	{
		"name": "language-git",
		"version": "0.19.0"
	},
	{
		"name": "language-glsl",
		"version": "2.0.1"
	},
	{
		"name": "language-go",
		"version": "0.43.1"
	},
	{
		"name": "language-graphql",
		"version": "0.9.0"
	},
	{
		"name": "language-html",
		"version": "0.47.2"
	},
	{
		"name": "language-hyperlink",
		"version": "0.16.1"
	},
	{
		"name": "language-ini",
		"version": "1.19.0"
	},
	{
		"name": "language-jade",
		"version": "0.7.2"
	},
	{
		"name": "language-java",
		"version": "0.27.0"
	},
	{
		"name": "language-javascript",
		"version": "0.126.1"
	},
	{
		"name": "language-json",
		"version": "0.19.0"
	},
	{
		"name": "language-less",
		"version": "0.32.0"
	},
	{
		"name": "language-lua",
		"version": "0.9.11"
	},
	{
		"name": "language-make",
		"version": "0.22.3"
	},
	{
		"name": "language-mustache",
		"version": "0.13.1"
	},
	{
		"name": "language-nginx",
		"version": "0.7.3"
	},
	{
		"name": "language-objective-c",
		"version": "0.15.1"
	},
	{
		"name": "language-perl",
		"version": "0.37.0"
	},
	{
		"name": "language-php",
		"version": "0.38.0"
	},
	{
		"name": "language-postcss",
		"version": "1.3.1"
	},
	{
		"name": "language-property-list",
		"version": "0.9.1"
	},
	{
		"name": "language-pug",
		"version": "0.0.21"
	},
	{
		"name": "language-python",
		"version": "0.45.2"
	},
	{
		"name": "language-ruby",
		"version": "0.71.0"
	},
	{
		"name": "language-ruby-on-rails",
		"version": "0.25.2"
	},
	{
		"name": "language-sass",
		"version": "0.59.0"
	},
	{
		"name": "language-shellscript",
		"version": "0.25.0"
	},
	{
		"name": "language-source",
		"version": "0.9.0"
	},
	{
		"name": "language-sql",
		"version": "0.25.4"
	},
	{
		"name": "language-text",
		"version": "0.7.2"
	},
	{
		"name": "language-todo",
		"version": "0.29.1"
	},
	{
		"name": "language-toml",
		"version": "0.18.1"
	},
	{
		"name": "language-xml",
		"version": "0.35.0"
	},
	{
		"name": "language-yaml",
		"version": "0.29.0"
	},
	{
		"name": "line-ending-selector",
		"version": "0.6.3"
	},
	{
		"name": "link",
		"version": "0.31.3"
	},
	{
		"name": "linter",
		"version": "2.1.4"
	},
	{
		"name": "linter-csslint",
		"version": "1.3.4"
	},
	{
		"name": "linter-eslint",
		"version": "8.1.7"
	},
	{
		"name": "linter-htmlhint",
		"version": "1.3.3"
	},
	{
		"name": "linter-js-standard",
		"version": "3.9.1"
	},
	{
		"name": "linter-php",
		"version": "1.3.2"
	},
	{
		"name": "linter-ui-default",
		"version": "1.5.4"
	},
	{
		"name": "markdown-preview",
		"version": "0.159.11"
	},
	{
		"name": "merge-conflicts",
		"version": "1.4.5"
	},
	{
		"name": "metrics",
		"version": "1.2.3"
	},
	{
		"name": "minimap",
		"version": "4.28.2"
	},
	{
		"name": "minimap-git-diff",
		"version": "4.3.1"
	},
	{
		"name": "minimap-highlight-selected",
		"version": "4.6.1"
	},
	{
		"name": "monokai-seti",
		"version": "0.9.0",
		"theme": "syntax"
	},
	{
		"name": "multi-cursor",
		"version": "2.1.5"
	},
	{
		"name": "notifications",
		"version": "0.67.1"
	},
	{
		"name": "one-dark-syntax",
		"version": "1.7.1",
		"theme": "syntax"
	},
	{
		"name": "one-dark-ui",
		"version": "1.10.3",
		"theme": "ui"
	},
	{
		"name": "one-light-syntax",
		"version": "1.7.1",
		"theme": "syntax"
	},
	{
		"name": "one-light-ui",
		"version": "1.10.3",
		"theme": "ui"
	},
	{
		"name": "open-on-github",
		"version": "1.2.1"
	},
	{
		"name": "open-recent",
		"version": "5.0.0"
	},
	{
		"name": "package-generator",
		"version": "1.1.1"
	},
	{
		"name": "permanent-delete",
		"version": "0.1.5"
	},
	{
		"name": "pigments",
		"version": "0.39.1"
	},
	{
		"name": "rename-tabs",
		"version": "0.2.0"
	},
	{
		"name": "set-syntax",
		"version": "0.3.2"
	},
	{
		"name": "seti-ui",
		"version": "1.8.0",
		"theme": "ui"
	},
	{
		"name": "settings-view",
		"version": "0.249.4"
	},
	{
		"name": "simple-drag-drop-text",
		"version": "0.3.4"
	},
	{
		"name": "smart-tab-name",
		"version": "1.0.5"
	},
	{
		"name": "snippets",
		"version": "1.1.4"
	},
	{
		"name": "solarized-dark-syntax",
		"version": "1.1.2",
		"theme": "syntax"
	},
	{
		"name": "solarized-light-syntax",
		"version": "1.1.2",
		"theme": "syntax"
	},
	{
		"name": "sort-lines",
		"version": "0.14.0"
	},
	{
		"name": "spell-check",
		"version": "0.71.4"
	},
	{
		"name": "status-bar",
		"version": "1.8.7"
	},
	{
		"name": "styleguide",
		"version": "0.49.6"
	},
	{
		"name": "symbols-view",
		"version": "0.115.5"
	},
	{
		"name": "sync-settings",
		"version": "0.8.1"
	},
	{
		"name": "synced-sidebar",
		"version": "0.4.3"
	},
	{
		"name": "tabs",
		"version": "0.106.0"
	},
	{
		"name": "timecop",
		"version": "0.36.0"
	},
	{
		"name": "todo-show",
		"version": "1.11.0"
	},
	{
		"name": "tree-ignore",
		"version": "0.6.2"
	},
	{
		"name": "tree-view",
		"version": "0.217.0"
	},
	{
		"name": "update-package-dependencies",
		"version": "0.11.0"
	},
	{
		"name": "welcome",
		"version": "0.36.2"
	},
	{
		"name": "whitespace",
		"version": "0.36.2"
	},
	{
		"name": "wrap-guide",
		"version": "0.40.1"
	}
]

#3

Remove the synced-sidebar package. It seems to be interfering with the new Docks feature.


#4

Thanks @Wliu, you made my night! :slight_smile:


#5

Yes, Thank you!!! I have been using SublimeText for a week now since I was having the same issue.