Turn on Line Wrap


#21

If anyone is having issues, you don’t have to hand edit your config.cson, just use the Settings View:

  1. Launch Atom
  2. Open the Settings View using Cmd+, on macOS or Ctrl+, on other platforms
  3. Ensure the “Settings” tab is selected (or the “Editor” tab is selected on Atom v1.11-beta or later)
  4. Scroll to near the bottom (the settings should be in alphabetical order)
  5. Check the box named “Soft Wrap”


#22

doesn’t work for me , v-1-10-2


#23

You need to describe your problem. What are you doing and how is Atom behaving?


#24

Thanks. This helped.


#25

The problem I’ve been having is when I first open a file in Atom, the soft wrap settings are not applied to the document. I have to close the file and then re-open it in order for the soft wrap to take effect. After doing this, all files open with soft wrap applied. I have soft wrap checked in the Editor Settings menu, and I’ve checked the confg.cson file to make sure that softWrap is set to true (softWrap: true). Any idea what could cause this and how to fix it? Thanks for the help :slight_smile:


#26

I can’t reproduce the problem you’re describing. I enabled Soft Wrap and launched a new Atom window. The untitled editor that showed up had soft wrap enabled.


#27

I don’t think that I had this problem when I first started using atom, but I haven’t been able to figure out what could cause it to start. It seems like the file is loading before soft-wrap is applied. If I close the document, then re-open it, the soft-wrap is then applied. Thanks for looking into it :slight_smile:


#28

I followed the debugging instructions listed here and found that the fonts package (fonts 2.0.0) using Robot Mono Medium was causing the problem. I disabled the package and the soft-wrap is now working on initial startup of Atom. I’m going to report the issue through the package manager. Thanks for the help :slight_smile:


#29

for line wrap permanent follow this step:-
1> open atom
2> open file option
3> select config option
4> find editor statement
5> In editor section paste
softWrap: true
for example:-
editor:
fontSize: 23
invisibles: {}
softWrap: true


#30

A much simpler way to do the same thing is to:

  1. Launch Atom
  2. Open the Settings View using Cmd+, on macOS or Ctrl+, on other platforms
  3. Click the “Editor” tab on the left of the settings view
  4. Put a check in the “Soft Wrap” setting

#31

This will not work because CSON requires proper indentation.


#32

My softwrap works in my html files but not in scss files. This is a snippet of what softwrap toggles ON does to my scss file

#intro {
  position:relative;
  width: 100%;
  height: 100%;
  border: 1px solid #ffffff;
  overflow: hidden;
  text-align: center;
  background-image: url(https://res.cloudinary.com/djhkdplck/image/upload/v1487649700/turntables1-bw2-test.png), repeating-linear-gradient(to bottom, #000 99.9%, #000 99.9%), linear-gradient(to top, #206020, white);

Could someone post their config file settings that has line wrap working correctly in their scss file please.


#33

Actually, the paste didn’t show the problem… there is a huge gap between the background-image property and value in my editor… probably around 80 spaces.


#34

Fixed my own issue: A paste of the cson file that I changed"

“.css.scss.source”:
editor:
preferredLineLength: 110
softWrap: true
softWrapAtPreferredLineLength: true
softWrapHangingIndent: 4
".sass.source":
editor:
preferredLineLength: 110
softWrap: true
softWrapAtPreferredLineLength: true
softWrapHangingIndent: 4


#35

By all means use softwrap internally, but please just call it linewrap in the UI.
It shouldn’t be necessary to Google for this feature after giving up in the menus.


#36

“Line wrap” refers to both soft and hard wrapping, whereas the feature in question specifically deals with soft wrapping. Therefore, “soft wrap” is a more precise term. In either case, the word “wrap” is present.


#37

Is there no settings in discluss.atom.io to push the correct answer to the top? And to change the correct answer since new release will change things?


#38

It’s ‘editor’:
softWrap: true


#39

There are some plugins that might offer those kinds of features but I haven’t investigated them yet. This is more intended as a discussion forum for conversations, not a Q&A site like StackOverflow.

As a reminder, the correct answer here is:


To turn on Soft Wrap:

  1. Launch Atom
  2. Open the Settings View using Cmd+, on macOS or Ctrl+, on other platforms
  3. Click the “Editor” tab on the left of the settings view
  4. Put a check in the “Soft Wrap” setting

#40

Any idea how I can turn it off? After activating soft wrap Atom will only toggle between soft and hard wrap. It wont go back to no wrap, putting everything on one line until return is hit.