Turn on Line Wrap


#1

How does one turn on line wrapping? I noticed I have to horizontally scroll in files with long lines. :smile:


#2

Never mind, I just needed to toggle Soft Wrap. I’ve never heard it called that before, sorry.


#3

Does soft wrap actually work for you? It doesn’t wrap at all for me.


Toggle Soft Wrap not working as expected
Autoclose-html package duplicates ending tags
#4

Yeah, it’s a little finicky. Using View > Toggle Soft Wrap is on a file-by-file basis (or so it seems). You have to have your active cursor in the file you want to change.

Making it global appears to be possible, however.

Go to Atom > Open Your Config

Add 'softWrap':true to the 'editor' section like this:

'editor':
  'softWrap': true

I hope that helps. :smile:


#5

HaHa! It apparently was working and I just didn’t realize because Atom doesn’t apply settings changes to open files. I had to close files and reopen them to notice it working.


#6

That should probably be considered a bug. For now that setting just affects the default for new files. You can turn on soft wrap on a per file basis with the “Toggle Soft Wrap” command. Also worth noting is the “Wrap At Preferred Line Length” setting if you’d rather wrap at 80 instead of basing it on the window.


Soft Wrap Not Working
Split screen + word wrap
#7

Ok… I was really confused by this, too. I just thought soft wrap wasn’t working at all.

Also notice that toggle soft wrap doesn’t have a checkbox or anything in the menu to know whether it is on or off, which is confusing, too.


#8

I had the same problem and this is the best option in order to fix to fix the problem, this feature definetly needs some improvement.


#9

That’s rock thank you


#10

Fantastic!


#11

Am I blind or there is no key-binding to this command? Neither ‘soft’ nor ‘wrap’ reveal it (nor ‘toggle’).
Should I open an issue to ask to add it?
I would like to have a quick way to toggle it on / off, particularly on Markdown files.

[EDIT] This belongs more to the Toggle Soft Wrap : Key Binding topic, but I leave it for those searching for similar thing… I searched in the key bindings, but since there is none by default, my search was empty. So that’s not a good way to search for a command, I should have used the command palette, as advised in the other thread.


#12

This worked! Thank you!


#13

If Atom does not soft wrap after you set softWrap: true, and then closing the working file, you might want to consider closing Atom all together and re opening your files. That seemed to do the trick for me. Cheers *


#14

I’ve set my config to turn off line wrapping as specified above and restarted. My file still wraps until I choose ‘View’ - ‘Toggle soft wrap’ on a per file basis. Is there any way of turning it off globally?


#15

Fantastic! This works for me and it keeps the soft wrap on every time I open Atom.


#16

This hasn’t worked for me. I changed the ‘softWrap’: true under ‘editor’: in the Config file. Then I quit atom and reopened my files. No change. I just have to click view -> soft wrap for every file I work with.


#17

If you share your config.cson, we could verify that it’s entered correctly.


#18

I know this hasnt had traffic in almost two months but what is the correct syntax on this?

"*":
  core:
    disabledPackages: [
      "emmet"
    ]
    themes: [
      "seti-ui"
      "monokai-seti"
    ]
  editor: {}
  "exception-reporting":
    userId: "d65d4e43-ce96-42d3-9e26-2c63573c59a4"
  "git-plus": {}
  minimap: {}
  welcome:
    showOnStartup: false

I add the line softWrap: true under editor here but then it moves it down to under minimal: {}


#19

If you use the check box in the Settings View, Atom will put the value in the correct location and you don’t have to worry about hand-editing the file.


#20

If anyone is having issues, the syntax provided above did not seem to work for me. This is what my final & working config file looks like with my USERID removed:

"*":
  "atom-material-ui":
    colors:
      abaseColor:
        red: 96
        green: 125
        blue: 139
        alpha: 1
      genAccent: true
      predefinedColor: "Blue Grey"
    ui: {}
  core:
    themes: [
      "atom-material-ui"
      "gruvbox-plus-syntax"
    ]
  editor:
    softWrap: true
  "exception-reporting":
    userId: ""
  welcome:
    showOnStartup: false