Turn off "take a break"

I am pretty new to atom and like it so far. But one thing is annoying like hell to me: Every some minutes there is this fullscreen pop up that says “take a break”, dims the editor and makes me grab the mouse every time I want to continue. I tried disabling most of the non-essential packages, so should not be one of those. Where is this coming from and how can I disable this “feature” (or rather, nag screen to me)?

It is a add-on package or a 3rd party app.
Can you tell us which packages are installed on your Atom?

Try the following in your OS terminal:
apm list -p
Show us what is listed under “community packages”.

There is not so many community packages and I think I already disabled all of them as a test:

Community Packages (9) /Users/xy/.atom/packages
├── atom-beautify@0.33.4
├── atom-clock@0.1.17
├── atom-clock-alarm@3.5.0
├── jump-lines@1.1.0
├── language-restructuredtext@1.1.2
├── last-tab@0.1.6
├── platformio-ide-terminal@2.10.0
├── set-syntax@0.4.0
└── sync-settings@0.8.6

Just tested it again: Disabled all of those community packages but still there was a “take a break” :frowning:

Also, I don’t have any “development packages” and no “github packages”. Only “core packages” would be left as the culprit.

Is the list you published, the same as what you GUI says you have?
Have you yet looked at which processes / apps are running on your OS?

  1. Yes.
  2. I started working with Atom on Windows 10, then today I used “sync-settings” to transfer settings and packages to a freshly installed Atom on my Mac at work. On both systems I get “take a break”. So, I guess the problem is Atom related.

What you are saying would make sense.
I am at my wits end.

Have a look at the .atom folder – the one that gets synchronized. Observe the files in the main folder (first ignore the sub folders). Do you see anything there that is out of place?

Next call up the files config and init (reached by FILE in the menu bar). Special attention to especially the config file. Some clue may be there in the settings (like: how long to next break).

If you are getting really frustrated: delete the whole .atom folder (Atom not open). Restart Atom and see what happens.

As recommended for all support requests, see if the problem persists after launching Atom in safe mode – this will launch Atom without third-party packages. Also, take a look at init.coffee if there is anything that might cause showing these reminders. Lastly, GitHub code-search is an excellent tool to find occurrences of the exact string you are being shown (without knowing the exact string, I found this package)

1 Like

The problem is gone now, but:

FOR ANYBODY WITH THE SAME PROBLEM:
I played around with the packages, gradually installed one after the other, and I am pretty sure the problem is: https://atom.io/packages/atom-clock-alarm

It’s the only package I have currently not installed. But a few days ago, when I did, there was no way to go back except removing the settings folder of Atom altogether.

You are right.
https://github.com/jqoker/atom-clock-alarm/blob/master/lib/atom-clock-alarm-view.js#L151