Turn off highlight feature


#1

Hello,

I cannot figure out how to turn off a certain feature of the Atom editor. When I highlight a set of characters and then begin to type to replace that string, the editor only allows me to edit an individual character, rather than free typing.

Please let me know how to turn this off.

Thank you!


#2

That’s definitely not standard behavior.
Does this still happen in safe mode (atom --safe)?
If not, there’s a community package messing this up for you.


#3

Ah, Okay. THank you for confirming. I’ll take a look and let you know. I wonder which package it might be?! :slight_smile: Stand by. I am in the middle of a big project so I’l have to wait to confirm / restart the editor.


#4

Looks like you were right! It was the atom-terminal-panel causing the issue. I disabled it, then restarted Atom and all is well. Thanks for the help.