Trying to install dependencies for a package using package.cson


#1

Hi, I am using a package.cson file for my project rather than a package.json file because I love trailing commas and comments.

Unfortunately, npm install . does not work (which is expected), but neither does apm install .. Is this a known issue? Or more specifically, if someone checks out my package from version control and wants to start hacking on it, how should they pull down the dependencies?


#2

It requires a package.json file, no .cson for now. But you can open an issue here https://github.com/atom/apm/issues


Why isn't package.cson supported? [actually it is]