Troubleshooting Snippets


#1

I have a simple starting snippet like this:

'source.scss':
  'Margin':
    prefix: 'ma'
    body: 'margin:'

But it doesn’t trigger in a .scss document.

Is there a troubleshooting mechanism in Atom to help find out why?

Or can someone see what’s wrong?


#2

Try .source.scss with the leading period.


#3

I should have seen that! But it didn’t fix it. I get $main-bg instead of margin:.


#4

It looks like the correct scope selector for SCSS is .source.css.scss:

And if you get $main-bg I suspect you have autocomplete-plus installed?


#5

Thanks. I keep forgetting to just check the language plug-in for the proper scope. :frowning:

Also, I did have autocomplete-plus running. When I disabled it, my snippet worked.

Is there way way to set priorities of snippets so that I might override autocomplete-plus? Or must I simply leave it disabled?


#6

I don’t know … I haven’t been keeping up on the development of autocomplete-plus. Perhaps if you had the autocomplete-snippets package too? :confused:


#7

Right you are! autocomplete-snippets fixed me right up. Thanks!