Trouble with remembering session


#1

Since upgrading to 1.7.2 my installation seems to have a huge problem with the session storage.

Even if I start in safe mode, and remove the projects, they come back next time. It opens two empty files and forgets anything I did have open.

I found a post that suggested deleting .atom/storage/application.json, which removed the ‘stuck’ project, but not it refuses to remember the current session.

Any ideas?


#2

I’ve just tried starting from a clean install then resyncing using sync-settings and it’s still not working, so I assume I’ve somehow corrupted my synced data?

Looks like I’ll have to reinstall each extension and settings manually…


#3

I had the same issue with Atom 1.7.2 installed from a snapshot for Arch Linux. I uninstalled it and installed it back, and the issue was gone. The same Atom version didn’t give me any trouble when installing on Windows.
Could you please write the operating system you’re using right now?


#4

I’m using 1.7.2 on OSX. It doesn’t seem to remember that I have the tree view open either. It’s like something is stopping it writing to one of the files…


#5

Did you try with deleting the hole ~/.atom/storage and ~/.atom/compile-cache folders as pointed out here and here?

As side note, I like to keep my configuration files saved in a repository, so I can carry my configurations everywhere and I don’t have to worry about losing them. In particular, this is my stored atom folder.

Hope this solves your issue!


#6

I deleted the entire .atom folder, and then resynced using sync-settings.

That’s a good idea - I did try previously copying the settings to dropbox for syncing, but it might be easier to set up a git repo.


#7

The session has been moved to IndexedDB mechanism instead of a files & folders structure.

I think atom --clear-window-state is the new delete session folder for atom >= 1.7

This should be documented somewhere /cc @leedohm


#8

Hmmm - first time I tried it, it remembered that the tree view was open, but didn’t keep any files open.

Second time it remembered the files, but forgot to keep the tree view open.

Third time, it worked.

So, thanks for the tip! :smiley:

It might still need some looking into though…


#9

the --clear-window-state solved this issue for me. Started happening after some update (I’m not really sure which one). There should probably be a better automated way to convert the window state when updating.


#10

It works for most people without a hitch.