Trouble inserting quotation marks


#1

I’m having some trouble to insert quotation marks.
I noticed that is because of my keyboard layout (I’m using US International layout), the key for 'also represents an acute accent.

For example, when I hit 'or " and after that hit the letter r, I get ""r". It inserts another quote before the letter, and when I delete the new quote, it erases the last quote too… so it’s pretty annoying.

When I change my keyboard layout to another one, like British, it works fine.

UPDATE

@DiogoAndre has uploaded an animated gif that illustrates this issue.


Quotes and U.S. International - PC keyboard layout
How to stop atom from auto closing and swallowing braces and quotes
Is there a way to mark threads as "resolved"?
Is there a way to mark threads as "resolved"?
#2

+1 for this. I’m also using the U.S. International - PC on my mac, because it allows easy typing of characters like é à ë etc.

The quotation marks should only be closed when you ‘confirm’ it’s a quotation mark, which is " + <space> for some keyboard layouts. Right now this: " + <space>lemon pie creates: ""lemon pie.

When you decide to give in and stop using the space and type "ew you get "ëw"

Ew, indeed!


#3

Also having this issue. For a while I thought it was solved, but I was just automatically hitting the :arrow_left: after the first quote, as a workaround.

Here’s a gif of what I’m seeing http://cl.ly/image/2M11082q262P

ps: I tried to upload the file directly, but ‘new users’ cannot upload images :cry:


#4

So… we don’t have a solution for this issue yet. It’s been pretty annoying to type words in languages that use acute accent (like portuguese, french, etc) in a International keyboard layout.


#5

+1

Same problem here.

U.S. International - PC keyboard layout.


#6

Very annoying indeed. Is that auto pairing quotes feature part of one of the open packages, or is it from the Atom core ?


#7

Same problem here.
U.S. International - PC keyboard layout + Mavericks

Any news?


#8

No replies so far.
I decided to stick with Sublime unless atom solves this issue.


#9

+1

Same problem here. I uninstalled all third-party packages, but the problem still happens.


#10

Yeah, it looks like a native issue.
I hope Atom fixes it soon.

And please, like the OP post so we can get more attention from Atom! :wink:


#11

I’ve been having trouble using a keymap to bind to “alt-n”, and I think it’s related. I don’t use an international keyboard layout (using plain old U.S.), but on Mac OS X, option-n makes this ˜ so you can type, for example, ñ.

Is there some workaround to disable this sort of thing by changing Mac keyboard settings? I actually don’t use or want the international characters, but it still causes me problems and preventing me from using Atom.


#12

Just to move this topic up and to make it clear that this is not a bracket-matcher issue: with US International keyboard layout, quotes currently don’t work in vim-mode also. (The reason why this is relevant is that bracket-matcher uses a strange way to listen to keys, while vim-mode correctly uses keymaps.


#13

It looks like the issue will be solved at 0.81!


#14