Treeview not showing ignored paths


#1

I know this has been asked before, but I think the issue I have is a bit different.

I have 2 installation of atom on 2 different computers (both are running latest OSX), same versions and same plugins, all of them are up to date. Also, same settings as far as I know.

On one machine, the treeview correctly shows the ignored paths in .gitignore by darkening their nodes color. On the other installation, this doesn’t happen anymore (I think after an update, but I don’t know if that’s involved by any means).

This happened to me once before, and I solved by completely removing the atom installation and by reinstalling again. Now this happened again and I am really struggling to know what the heck is going on here. Any ideas?


#2

Are the config.cson and styles.less identical between the two computers?


#3

Actually, the vcs ignore flag was set to true in one of the two installations, the one that was not working. Thank you very much for the tip, but I really don’t get it: shouldn’t be that flag bound to the Exclude VCS Ignored Paths option on the core settings panel? I had THAT disabled on both computers.


#4

They control two different things. (I need to make a FAQ about this, actually.)

Exclude VCS Ignored Paths controls whether certain packages should ignore version control ignored paths when performing project-wide functions, like fuzzy-finder.

The Tree View Hide VCS Ignored Files is specifically for showing or hiding version control ignored files in the Tree View, separate from the above because some people like to see the files even if they’re not included in project-wide functions and vice versa.


#5

Thank you, now I got that. I clearly misread the docs.