Tree View text is Dim, Dark, Faded, and Icons are not in Color


#1

For some reason my tree view doesn’t appear like most people who have posted screenshots. This is using the Seti UI. But it is the same with all of them. The text is very faded, hard to read, and the icons are not colored. I did not change any CSS in the base, yet maybe I tried a keyboard shortcut which did it.

It’s driving my nuts. What setting am I not seeing? Thanks.


#2

It looks like everything in the tree view is grayed out because it is covered by your .gitignore?


#3

I emptied out my .gitignore file, did View > Reload, and it changed nothing.

It is almost like everything is set to be grayed out? However I am only using the defaults.


#4

If you open the dev tools and inspect the tree view elements, do any of them have the CSS class of .status-ignored?


#5

I just noticed this… going way out and accessing my User folder in Atom does not ignore these files

And yes! Every single one has a class of .status_ignored. Is my git messed up?


#6

For some reason, Atom thinks that all those files are ignored. So whether it is because there is a .gitignore that is marking them that way or because you’ve changed your “Ignored Names” setting in the Settings View … there is something that is making Atom think that.

You can use the git check-ignore command to determine if Git is ignoring a file or directory.


#7

Also check your global git config, since local .gitignores are not the only ones checked by git.


#8

Here’s the .gitignore and .gitignore_global from the User dir.

Not sure what to do here. Removing/Reinstalling git completely due to this would not be fun.


#9

You don’t need to reinstall Git. Besides, that wouldn’t help :disappointed:

The first line in your .gitingore is /*, essentially you’re saying “ignore everything” and then you walk it back with a bunch of negative ignores (the lines that start with !). This is a really complicated way to do things and is prone to errors. You should probably start with just ignoring the things you don’t want to see in the repository … rather than trying to use .gitignore to whitelist things.


#10

That was it. For some reason the .git_ignore file started with /*, and as you said, was ignoring everything.

I’m not sure how it got this way to be honest.