Tree view package has no setting area


#1

I use Atom 1.11.2. On some video about Atom tutorial a saw that, the tree-view package has setting room, but when i open the setting, just Disable button there. When I move to install-package, there is setting button at treev-view package, but when i click on that, a setting room has nothing except the big text READ ME.

What i need to configure because on tree-view panel, the .git folder here - what i expect not exists. On core setting, I also unchecked the VCS option but it like nothing change.

So, my question: why there is not setting room for view-tree package, and how i can hide the .git folder, .gitignore file.


#2

The tree-view package does have settings. You can get to it like the settings for any other package after opening the Settings View using Cmd+, on macOS or Ctrl+, on other platforms:

The tree-view package has a separate setting for whether to display or hide VCS ignored files.


#3

The problem is fixed. When I restart Atom by Ctrl-Alt-R, tree-view package has Setting-Button appear again, and all option include Hide VCS Ignored Files. I think this problem is hatched when i install some packages or figure another settings, may be linter or nuclide. On fact, after I disable nuclide, i can figure the tree-view-setting now.

Appreciate so much for your help. :slight_smile: