Tree-Sitter: Package won't show up in list


#1

I have this really weird bug: I was trying to test my new tree-sitter grammar. When I open a new file with a matching extension, Atom will choose the new grammar correctly. But I can’t find the grammar in the list, when I click on the grammar name in the lower right corner.

Put simply: Tree-sitter based grammars don’t show in the Grammar Selector.

Has anyone experienced the same?


#2

It’s known at least, just not acted on yet.


#3

Oh, okay, I opened a issue about this myself, at least there is some kind of “workaround”


#4

I just let it select the grammar when I open the file. If there’s a conflict, you can (temporarily) register a new file extension for the grammar, and change the test file extension to match.

Hopefully I / someone else will fix that issue soon though. We’re moving closer to turning on Tree-sitter by default, and community package support is still not really as good as it should be.


#5

So, finally got it to run. I really like it! I was skeptical first, but I first wrote down my grammar in EBNF, translating into a tree-sitter parser and testing it worked like a charm. Hope you guys fix this soon, this would make Atom even better.

Writing assembly/machine code grammars was a pain up until now, with this it would be a breeze.