Trailing whitespace


#1

So, I used a package for displaying trailing whitespace in Sublime, I was disappointed when I didn’t find a similar in Atom. I didn’t need to be, golly how simple to fix.

.editor {
  .trailing-whitespace {
    background: pink;
  }
}

#2

But how can you remove them on save?


#3

Hmm, it seems like the Remove Trailing Whitespace option in the Whitespace package isn’t working correctly anymore.

EDIT: Scratch that. A new option has appeared Ignore Whitespace On Current Line. So the removing of trailing whitespace doesn’t work on the current line, if you have that option sat to :heavy_check_mark: (Default)


#4

Is this option changed as of version 1.0 ? I am not seeing it working :frowning: .

ctrl + shift + p => typed whitespace and clicked on remove trailing spaces. Nothing happened .

EDIT : Clicking on Packages->White Space->Remove Trailing Whitespace helped.

Thank you.