Toggle Tree View, Lose Focus


With the tree view open on the left and an editor pane open on the right, I can invoke Toggle Tree View from the menu and the tree view pane disappears, just as it should.

But if I toggle the tree view back, the tree view pane returns, but the editor pane loses focus and I can’t get it back into that pane without changing to another open tabs and returning.

Is that expected behavior?



If the tree view has focus, you can toggle focus between the tree view and the editor panes by pressing Ctrl+0. As far as whether or not the tree view gaining focus on being toggled on, that is at least consistent with other views … find and replace, command palette, even opening a new editor tab. They all gain focus when brought into existence.


The problem is that when I click in the editor pane to put focus there again after showing the tree view pane, the click does not move the focus to the editor pane or display the cursor.


I can’t reproduce that behavior on the following:

  • OS X 10.9.3
  • Atom v0.102.0-f9c975b

What OS and Atom version are you using @bobrocke?


I’m running OS X 10.9.3 and Atom v0.101.0. Mine shows no upgrade available, do I need to download v0.102.0 manually?


No, when there is a hex string after the version number that means that it is built from source. v0.101.0 is the latest released version. I just installed v0.101.0 and still could not reproduce the bug you describe:

Can you reproduce the error with atom --safe?

v0.101.0 Click Missing Target

Yes. Running atom --safe and opening a file, clicking in the edit pane produces no cursor. Opening another file and switching to that tab returns the cursor.

Toggling the tree view pane open/close moves focus to the tree view but clicking in the editor pane does not produce a cursor until switching to another open file tab.


I would try completely reinstalling then. I’ve never seen the behavior you’re describing. It might help if you use something like LiceCAP to record a GIF so we can all see what you see.


OK. I figured it out. I was using the React editor option. Turning that off and restarting Atom fixed that right up.


Can you file a bug for this if there isn’t one already?


Looks like there is a fix being worked on for this:


@bobrocke We just release v0.102.0. I think upgrading to this will your problem!


This is still happening in the latest version of Atom


Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have the Shadow DOM feature enabled?
  • Do you have the Emmet package installed?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

Please include detailed repro steps, because I just tried it and could not reproduce the original issue.