Toggle Soft Wrap by Default?


#1

Hi. Every time I open ATOM I have to View > Toggle Soft Wrap for every pane.

There must be a way to latch it by default?


#3

Settings ➔ Editor ➔ Soft Wrap


#4

Oi, I skimmed right over it. Thanks Aerijo!


#5

New Atom user here. I had the same question as ARNK. I had not yet found the View > Toggle Soft Wrap and was simply looking in the Settings > Editor section. I had read several discussions about soft wrap and was attempting to adjust my settings to my liking.

Basically, I just want soft wrap off completely. I had not been able to achieve this using the Settings > Editor section, but when I did View > Toggle Soft Wrap, I finally was able to remove soft wrap altogether.

My Settings > Editor settings are as follows:

  • Soft Wrap: unchecked
  • Soft Wrap At Preferred Line Length: unchecked
  • Preferred Line Length: default (80)
  • Max Screen Line Length: default (500)

I read somewhere that the Editor settings only apply when a new editor pane is opened, so I tried adjusting my settings and then re-opening the file I was editing, but I couldn’t get much of a change. (I was able to get it to wrap at a smaller column value, but not to turn off soft wrap entirely.)

I can set up a keyboard shortcut in macOS to perform View > Toggle Soft Wrap easily, but it seems like the “hackable code editor” should be able to be configured exactly how I like it.

I am running 1.30.0 x64 on macOS.

Have I missed something?


#6

Languages can override the global setting. If it’s a particular language you are experiencing this with, go Settings -> Packages -> language-<language name> -> Soft Wrap. You can see all language specific settings changes direclty in the config file.

Some language packages, such as for LaTeX, enable it by default. This is because these languages are often used to write long lines of text. In this case, it will need to be explicitly overridden by toggling the setting.

That’s not normally true, but reloading Atom is the first thing to try when something doesn’t work.


#7

Thanks for the quick response. I’m currently working on *.md files. It doesn’t seem like a particular language would apply to that. Any suggestions?

The very specific details of what prompted my issue are formatting tables in my *.md file for display in a markdown preview. I want my tables to have their column delimiters aligned even in the *.md file (yeah, I’m weird, ok?), but was getting issues with the rows wrapping, which breaks what I’m trying to see. Executing a View > Toggle Soft Wrap gets me what I want, but it’s not immediately obvious to me what setting is affecting the file type/language I’m using.

I did check the settings in my language-text package, and nothing appeared amiss (Soft Wrap and Soft Wrap At Preferred Line Length are both unchecked).


#8

Markdown is (by default) provided by language-gfm, and is highly likely to have soft wrap enabled by default.

I understand the table issue; I have it too in LaTeX. I tend to do all my table editing with it disabled, be re enable when I’m done.