Toggle-line-comments doesn't activate that functionality despite the keybind being valid


#1

I’ve run into an issue where Ctrl-/ shows as activating the editor:toggle-line-comments functionality, but nothing actually happens in the file. Rebinding this (to e.g. ctrl-i) doesn’t change the behavior, and running atom in --safe mode also behaves identically.

An example of the keybind resolver when I use the ctrl-/ bind:

This was working for me around Nov/Dec last I recall. I use a Logitech G710+ keyboard with a US language setting and haven’t had an issue like this before in atom.


#2

What language are you using when trying to comment out lines?


#3

That narrowed it down - it’s an update to https://atom.io/packages/language-arma-atom that seems to have caused the issue. I assumed the commenting would apply to any file in safe mode, but I guess not. Disabling that package restores normal behavior. I’ll file it with their tracker. Thanks!