There seems a bug while dealing "fi" words with monospace font such as Monaco?


#1

I’m using the Monaco font, and I found that there seems a bug while dealing monospace font, that is, it was not in the same width, the word with “fi”, you can see, will be in one-character-wide place, instead of two, and if you move the cursor, you’ll find it jumps two character wide while you pressed once. How to solve it?


#2

That’s a ligature that is part of the font. To disable ligature substitution, you could try using the font-feature-settings property in your stylesheet.

/* untested */
.editor { font-feature-settings: "liga" 0; }

#3

Thanks! I’ll try it now.


#4

It works! I’ll learn more about it.