Theme not changing


#1

I’m trying to change the theme of atom but after I changed the theme in settings nothing happened.
Is there is a bug?


#2

Could be, but a bit more information would be useful; are you attempting to change the syntax theme or the UI theme? Also which theme, what OS are you running Atom on, and which version of Atom?


#3

I tried to change both to atom light, I am using windows 8.1 pro with the newest atom version.


#4

Just to be precise, since the versions change rapidly. Is it v117 then?

Are you able to change to any other theme, or is it not working with any of them?
Can you install new themes ok?


#5

I can install themes but after the installation when I trying to change to the theme I just downloaded it still stays with the default theme.


#6

@rafaelzilberman Did you install via Chocolatey by any chance?


#7

@batjko
I tried first the zip file, it’s not worked so I installed it from chocolatey.


#8

Ok, and the zip version gave you the exact same problem, or something different?


#9

@batjko Exact the same problem


#10

Alright then…

Could you open your Developer console and post the output you get when you try to switch to a new theme (i.e. Ctrl-Alt-i).


#11

Same problem here and I solve it.
from the Developer console information ( thanks @batjko ) it seems like the default config file has some wrong.
Click File->Open Your Config and remove the line only has : false.
At least it works for me.


#12

Same problem here; can’t change the theme no matter what I do. The settings checkboxes always revert back to “atom-dark”, whenever I close/open the window.
Layout always looks the same (bland atom-dark, getting tired of it).

Please fix this soon?

This is on OS X 10.9.4. Atom 0.123.0

Ps.: incidentally, the same problem seems to apply for line wrap settings; atom keeps forgetting them.
Pps.: @zhi solution did not work for me.


#13

I am getting the same issue. It tells me in the console that the theme is not installed. I tried removing and re-downloading the packages, but that didn’t help.


#14

material-ui is not the same theme as atom-material-syntax. The theme you show in the screenshot is atom-material-syntax and the error message mentions material-ui, so it is entirely possible that the error message is correct.