The mac application won't open from /Applications or finder


#1

MacOS 10.11.4
Atom 1.7.2

When I click on the Atom icon from the Finder or select open with… , Atom will launch but no windows will open. There is a menu, but it has a single entry for Atom.

When I launch atom from the command line it works fine so I can’t run it in debug mode to try to figure out what’s going on. I deleted all of the atom settings I could find to try to reset it but no luck. I also tried the beta with no change.

Are there any suggestions what could be going on here?


#2

Try launching Atom from the command line with atom --clear-window-state and see if that helps.


#3

I tried --clear-window-state and it didn’t change anything. If I launch from the terminal and leave atom running in the dock, it will work as expected. It seems like it’s something in the mac packaging not the executable.


#4

What shell do you use when you launch the terminal?


#5

Same issue occurred in my environement.

  • Click Atom.app, Atom is launch, but window is not appeared.
  • Command atom. it works fine.
  • After the window opened by command line, Command + Shift + N (New Window Open) doesn’t work.

Environement

OSX El Capitan 10.11.5 (15F34)
Atom 1.8.0
Shell:

$ echo $SHELL
/bin/bash
$ bash --version
GNU bash, version 3.2.57(1)-release (x86_64-apple-darwin15)
Copyright (C) 2007 Free Software Foundation, Inc.

#6

@tomorrowkey Where do you have Atom.app installed?


#7

Atom.app is installed in /Applications/Atom.app.
I found Atom.app symlink in ~/Applications. But the link target is already deleted. (Maybe this symlink is created by brew cask)
I delete it, but problem still occurred.


#8

atom command is a symlink. It is linked to /Applications/Atom.app/Contents/Resources/app/atom.sh.


#9

It’s curious that the command from the terminal works, but launching from the icon doesn’t. Where does the icon point to?


#10

The icon which I clicked is located at /Applications/Atom.app. I clicked it directly. This is not in the Dock.
Sometimes I launch Atom with Alfred. It is also point to /Applications/Atom.app.


#11

I’ve updated Atom to v1.10.0. The problem still occurred…