Text indent via tab key not working


#1

Text indent is not working for me if tab key is pressed, Editor:Indent does work though. I am not using Emmet (a problem suggested in a different issue).

This is on MacBook with OS X 10.9.2


#2

Some questions …

  • Can you reproduce the issue when running atom --safe?
  • Are you running my emacs-flow package by any chance? :laughing:
  • If you bring up the Keyboard Resolver with Cmd+. and then press TAB, what is shown?

#3

The keyboard resolver did the trick for me - disabling the snippets module solved my problem.


#4

I also recently ran into this, disabling snippets fixed it for me as well.


#5

Same here, tab key was broken, disabling Snippets plugin fixed it.


#6

Same here. Keyboard resolver says it does “snippets:next-tab-stop”. Should be editor:indent, isn’t it?


#7

The keybinding resolver generally says a lot of things for TAB because a lot of different things use it. But only one binding wins. Which one wins depends on the context. Here’s me just pressing TAB at the beginning of a line:

And this is me pressing TAB after entering something that I know will expand into a snippet:

I haven’t ever been able to duplicate the issue that has been mentioned here. The TAB key has always just worked. (Though as @docbobo mentions, there is a confirmed bug with TAB and Emmet.)


#8

In my case “snippets:next-tab-stop” always wins, no matter where I am. Btw I’ve found that this issue exists only for git-powered projects. Disabling of “Git diff” or “Snippets” plugin fixes this issue.


#9

Ok I’ve removed ~/.atom completely and reconfigured from scratch. Installed same packages, copy-pasted stylesheet/keymap configs and now tab works.

Diff of config folders shows that underscore-plus version in packages dependencies was updated from 1.5.1 to 1.6.1.