Terminal Error involving AVD_loader.cpp


#1

I have been seeing the error message (listed below) come up once the app launches in the terminal with every single app I have written so far. I just started learning how to use Electron so I am not very experienced. I tried searching for a resolution but had no luck. Maybe someone here can help?

The error is… /Library/Caches/com.apple.xbs/Sources/AppleGVA/AppleGVA-9.1.12/Sources/Slices/Driver/AVD_loader.cpp: failed to get a service for display 3


#2

I had a similar problem that prevented the app from displaying anything. Turned out to be a typo in my win.loadURL() call. Fixed it and the app displays the page. The error still shows up but it seems to be working. That’s not right, but at least I can continue learning. I’ll post more if I figure it out.


#3

I’m pretty much in the same boat as you. However, I didn’t have any issues with the loadURL function since everything was loading up correctly. My terminal just keeps logging that message. I read something about it being related to a possible issue with Chromium and the latest releases of OSX. I could be wrong though. Hopefully someone can shed more light on it at some point. Thanks for the reply retz.


#4

same, except I get “display 4” =\


#5

I have the same problem and could not find any solution yet. The app works fine, but it still reports this error on the Node terminal log.


#6

I am currently getting the exact same thing. Not sure how to fix this. There seem to be a couple of cases reporting the same thing without solution.


#7

Got the same issue on my Mac OS Sierra (X.12.6).
I found someone who suggested to fix it with :
app.disableHardwareAcceleration();
It works, but as far as I understand, I disabled graphics acceleration, right?
I don’t know which is best: keeping error logs and an app running well (hopefully) or having poorer graphical perfs but no more errors?