Tabulators are not aligned correctly


#1

I’ve deactivated the soft tab option in the preferences.
Using tabulators does not align the text correctly. Looks like the offset is not correct.

I tried this example text:

asdasd	asd
asdas	asd

Soft Tabs are harder than they should be
Soft tabs should follow tab stops
#2

Looks like this is a duplicate of this issue …


#3

It’s not a duplicate; as the topic you mentioned discusses soft tabs. I am not using soft tabs.


#4

There are a few threads all discussing some different issue about tab stops or the tab key and their behavior. There is at least one that covers your specific issue. Please use the search function and add a like or comments to the one most appropriate.


#5

It would be nice to hear something from the project on this; for me personally its enough of an annoyance that I’ve stopped using Atom.


#6

+1 @tobiasmuecksch

Tabs don’t work correctly even non-Soft Tabs mode.

@leedohm I’m afraid this is not a duplicate of Soft tabs should follow tab stops. The issue you’re referring to is is how many space characters are being inserted into the actual file.

Unfortunately another thread - Tab stops not rendering properly? - has also incorrectly been marked as duplicate and was closed but is actually referring to our issue.

The issue at hand is another, different one - whether tab stops are not rendered correctly without inserting additional space characters.

Can you please add this to your Issues list, @leedohm ?

Thank you!

Best,
Andreas


#7

My issues list is the list of topics on the board. I’m not an employee of Github nor a member of the Atom team … just an enthusiastic helper :smile:

It would help if exact repro steps could be spelled out as well as expected and actual behavior. Here is the way that I see this:

One thread is saying that “when I type X I should see Y in soft-tabs mode”. The other is saying “when I type X I should see Y in non-soft-tabs mode”. You are both asking for the pressing of the tab key to act as if it has a variable width, i.e. align with “tab stops”. I don’t believe that this really has anything to do with whether or not soft-tabs is on. To me, the issue of soft-tabs mode is just a distraction. Both threads are asking for tab stop behavior. I do not see why the two topics cannot be joined into one asking for tab stop behavior regardless of soft-tabs mode setting.

But, @tobiasmuecksch was very insistent that these are not the same issue, so I left this topic open.


#8

Thanks @leedohm :slight_smile: Sorry about my confusion, your enthusiasm looked like that of a Github employee :wink:

Well, this might be an implementation detail, but my understanding is that the functionalities of soft-tabs and real tabs are fundamentally different. They do share the computation of the next tab position though, and my totally random guess is that this is what’s gone wrong. But that’s just a guess of course.

I’ll go with your advice and report the defect properly.

Thanks, @leedohm!

A.


#9

Thanks @AndreasPizsa :sunny: Have a whale :whale:


#10

Just a brief update from the project team (@pixeloution ):

I reported this issue to the Atom team using the “send feedback” functionality in the app. I received an email saying that issue is being tracked, but there is no ETA, so apparently the prio is currently not super high.

It is for me though :slight_smile:

So anyone who feels likewise, please like this thread, comment here with a simple +1 and/or use “send feedback” from within the app to raise the priority on this.

Thanks :slight_smile:


#11

@AndreasPizsa It’s enough of an annoyance for me that I’ve stopped trying to use the editor and I’ve gone back to sublime until they get it sorted. It may seem trivial to some but its a show stopper for me.


#12

I opened an Issue on that: https://github.com/atom/atom/issues/2181

Since Atom is open sourced, we could try to fix it ourselves!

Does anyone have a guess, where in the code the problem could be located?


#13

This is the only thing preventing me from using Atom. Would love to see this fixed!


#14

Same for me and several others i know too.


#15

Finally there is a pull request claiming to fix this lousy issue. Hopefully the atom developers will merge it soon.

See:


#16

Thanks for keeping an eye on this @tobiasmuecksch!


#17

This behaviour is horrific. I was having such a great time with Atom too, but then I realised that I can’t sanely align things using a 4-space soft tab while not pushing 8-space actual tabs to GitHub …

The default behaviour should be exactly like Sublime Text. Enough people like that behaviour, and isn’t that the normal softtab behaviour everywhere else?


#18

Please Fix!!!
A development editor must have tab alignment!!!


#19

Just in case people aren’t watching atom/atom. @kevinsawicki has asked for help from the community on checking his potential fix for this issue:

If anyone has any particular files with complex hard tab alignment, I’d love to test them out to make sure there aren’t any corner cases that were missed, thanks!

The conversation is here: https://github.com/atom/atom/issues/1845#issuecomment-46490173

The PR is here:

Go ahead and post your submissions on #1845.


#20

Looks like this is fixed in v0.105.0:

Hard tabs now correctly align to proper tab stops.

Unless people say that it isn’t … I’m going to close this topic in the next day or so.