Tabs just became huge for no reason?


#1

I just opened my editor and I noticed these tabs are way larger than they used to be. There’s tons of wasted space, did a setting get changed or something? Is there something I can do to reset it back to the way it used to be?


#2

In the release notes for v0.197.0:

The One UI themes now have a setting to switch between 3 layout modes. Auto, Compact and Spacious. In Auto mode, the UI and font size will automatically change based on the window size

And it appears you’re using the One Dark UI. You can go into the settings and choose the Compact mode.


#3

Sounds right, but I can’t find the settings for it? I checked the general settings and the theme settings.


#4

You should go to the themes tab in the settings view. Scroll all the way down until you see ‘core themes’ and the one dark ui theme. It should have a settings button that takes you to the theme’s settings.


#5

@mpkarlo There is another thread with some screenshots: How to make the tabs smaller? I’ve seen an issue that if a theme adds settings, you have to reload Atom first to see the settings button.

Also see this comment in case you wanna customize it further: How to make the tabs smaller?


#6

Thank you all, I found it. That having to reload Atom must have been it. I swore up and down I couldn’t find it, then was baffled when I tried it again this morning after reading olmokramer’s post. I might just check out the other thread, too. I still find them way to big.


#7

The media query that enlarges the fonts on large screens doesn’t feel that good to me. All text (and by extension tabs and tree-view) becomes a lot larger, just going from 11px to 12px, than any other application on my desktop. No other application does that and it just feels very random and unnecessary: I don’t have a hard time reading the text in any other application on my large screen.
I’m now using compact mode, which is fine, but I still just don’t understand why text is enlarged in a media query.


#8

I think @mpkarlo meant that the tabs are now wider in general, regardless of the layout mode.

There is an issue open about the font size changes in Auto mode: https://github.com/atom/one-dark-ui/issues/62#issuecomment-100435280. You could lock the font size in styles.less also in Auto mode, but that’s probably hard to discover. An option would be to add a separate setting for the font size.