Tab length of '2' not respected for C++, but all others seem to work


#1

I have set a tab length of 2 (with soft tabs) in the language-C module for C++ and 4 spaces are still being produced in my C++ files. The particularly odd part is that if I set it to any other value (I’ve tried 1, 3, 4, and 5) it works correctly, so I assume I am in the right spot. Furthermore, the indent guide DOES always work correctly, based on where I set the tab stop. Is this a known problem? Am I doing something obviously wrong?

Thanks!

— Charles


#2

Fixed it.

I had installed the language-cpp14 package and apparently BOTH it and language-c were adding the two spaces. I’m not sure why it worked correctly when I was using values other than two.

I’ve disabled language-cpp14 and all is good.