Tab-indent gone haywire?


#1

Hi,

I never ever use tabs so want my old Emacs style auto-indent on tab. This has worked fine before:

  'atom-text-editor:not([mini, autocomplete-active])':
    'tab': 'editor:indent-selected-rows'

But all of a sudden this no longer works. I get tabs inserted unless I have selected text, this was not the case before I’m pretty sure. How can I remove the insertion of tabs?


#2

You should open the keybinding resolver and screenshot what it shows when you press tab.


#3

Well, I can’t really because the keybinding resolver minimizes as soon as I try to screenshot it (any control key will make the pan minimize) :slight_smile:

But I can tell you what it says which is no surprise:

editor:indent atom-text-editor:not([mini]) from core:cson

That’s from core:base.cson:

"atom-text-editor:not([mini])": {
   …
    "tab": "editor:indent",
   …
  },

However, in my user settings I have:

'atom-text-editor:not([mini, autocomplete-active])':
    'tab': 'editor:indent-selected-rows'

which previously have overridden without issue.


#4

That core keybindingseems to have been the same since 4 years so that’s definitely not it:


#5

Hello.

Sorry to ask - could you explain in more detail what result you are looking for.

The settings inside Atom provides for changing indent for tabs to “soft tabs” (read: spaces). Indenting takes place automatically according the grammar specification and to the indenting spaces you have specified.

Selecting code and pressing TAB works out of the box. For one line, the cursor needs to be at the start of the line (before first word).

So… what is your requirement exactly?


#6

You could click on your desktop so that Atom’s not in focus and then take the screenshot. Or you could use something that doesn’t trigger on hotkeys.

But I can tell you what it says which is no surprise:

editor:indent atom-text-editor:not([mini]) from core:cson

We know which command is being triggered, but I’m more interested in the other information that the panel provides, about which commands are matched but not executed and which commands are not matched at all.


#7

I want to trigger “editor:indent-selected-rows” with tab even if not selecting multiple rows or having cursor in the beginning of row.

Edit:
To be clearer, I never ever want to insert tabs or soft tabs/spaces anywhere but in the beginning of the row. I have no need for tabular edits in text documents.


#8

That took some work. I’m a tabber, haven’t seen my desktop for years… Know no way of doing screenshots with OSX without modifier keys, all of which made the it minimize :slight_smile:


#9

The problem is your CSS selector. It’s not valid, so it’s not getting matched at all. Try atom-text-editor:not([mini]):not(.autocomplete-active).


#10

Thx! Awesome!